2 - CyberPanel on SSL

Note: If your domain is behind Cloudflare it will not work since CloudFlare blocks port 8090.

If you want to access CyberPanel on SSL you can do so by issuing Lets Encrypt SSL for hostname, before continuing further make sure you have created website with a domain you want to access CyberPanel as.

If you want to access CyberPanel on: https://panel.yourdomain.com:8090 , create an account with domain panel.yourdomain.com. While creating an account you can either check SSL or not, it is optional.

If domain still does not point to the server, again a self-signed SSL will be issued.

Setup SSL

Main > SSL > Hostname SSL

Select domain on which you want to access CyberPanel. Once issued, you can visit CyberPanel on https://yourdomain.com.

Note: If you also want to host websites on this domain, you can do so by simply using FTP or File manager, this operation will not affect that.

1 Like

I followed the above method and now I can access Cyberpanel with valid SSL at https://domain.com:8090 (https://domain.com:8443 with Cloudflare). But when I try (http://domain2.com:8090) the connection is not encrypted. Is there any way I can block access / 8090 ports on http://domain2.com

Change panel port to 8443 from cyberpanel settings

Before changing port from here
add the port first in firewall and then change here

What I want to change is to limit cyberpanel access to example.com:8090 and block access to cyberpanel from example1.com:8090 and example2.com:8090.

I configured cyberpanel login to example.com:8090 with SSl but when I write example1.com:8090 , cyberpanel is accessible without SSl.

Im a little new to this as well, but i believe you would let that in your firewall / port forwarding on my security gateway. aslo check you dns records with your provider. I have my IP_ADDRESS of cyberpanel with port 8443 opened. I couldnt access port 8090 (locally worked fine) until i added it in port forward rules, same with 8443. Cyberpanel is now pointed to my domain so i can offer services.