Accessing Cyberpanel Via Hostname with SSL

So I just got Cyberpanel setup for the first time. I decided that I wanted to access Cyberpanel via domain rather than IP, so I created a website for it at

I created an A record with my registrar (which is still managing the nameservers for now) of panel and set it equal to my server IP address

I then used cyberpanel to issue a hostname SSL for installation:

I got the greenlight that the SSL was issued for the domain.

Now when I try to access cyberpanel via hostname: my site/installation of cyberpanel is found, but the browser reports that location isn’t secure, and I have to go through the whole “your connection isn’t private” advanced approval stuff.

Any ideas as to what step or steps I am missing?

I’m not sure I follow, but what kind of custom configuration? Are you able to point to something. I followed the guidance provided here:

@brad7 - I’m pretty sure I did that unless step 3 has to be done via SSH from the command line.

What I did was this:

  1. Create new website on the domain I wish to use, in my case “
  2. Create hostname SSL for that website.
  3. From cyberpanel > server > LiteSpeed Status > REBOOT LITESPEED
  4. Access via “

And the panel does load, it just doesn’t show as secure.

Well, I didn’t make any changes, and it’s working now. So I guess I managed to do it correctly after all. My guess is that it was either a propagation or caching issue on my desktop.

I might setup another one later just to confirm that I actually know what I’m doing and didn’t just get lucky. But whether it was luck or skill, it seems to be working as I intended now. So, I’ve got a lot of work to do getting everything moved over to my new server before I go testing and tinkering.

@jaceman - I am glad you got it sorted! Sometimes that is an issue, I usually use a 4G connection to quickly validate changes when it may be cached on the PC or network level.

I’ve got the same problem before:
Make sure the DNS has already been resolved and pointing to your server. Check it with Only after that you generate the SSL

If above step didn’t work, mostly it’s because of your cache. Try to disable your browser cache and open it again.

Hello actually this problem appears again after a while I hope that does not happen to you


In a bit of a mess here, accidentally deleted the hostname site.

Please advise how to access Cyberpanel after deleting “” from server?

I tried to change hostname back to IP using " hostnamectl set-hostname" but it doesn’t allow panel login page to load.

I also tried to change hostname to another url still present on Cyberpanel but it doesn’t have hostname SSL hence panel login page does not load.