Php 8.1 ioncube extension

Hi I couldn’t find the ioncube extension for php 8.1 in my cyberpanel. How can I install?

check this

1 Like

Hello, thanks for your reply.
I tried the below command but it didn’t work.

bash <(curl -Ls

read below post to get it work

Which article are you talking about?
I read all the posts, but I can’t solve this error.

@zaku here is the solution

Check your extension directory for your default assuming php 8.1 is default php -v

php -i | grep extension_dir

Try this :

sh <(curl || wget -O -

Confirm using php -v you wil get something like:

PHP 7.4.33 (cli) (built: Nov  3 2022 07:46:18) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with the ionCube PHP Loader + ionCube24 v12.0.3, Copyright (c) 2002-2022, by ionCube Ltd.
    with Zend OPcache v7.4.33, Copyright (c), by Zend Technologies

Hello, thank you for your reply.

When I ran the first command, I got the following output;

When I run the second command, I see the same error again;

Now i get you. You are using CentOs. Here is a fix for you:

$ cd ~ && wget

$ tar -xvf ioncube_loaders_lin_x86-64.tar.gz

$ cp --verbose ioncube/ /usr/local/lsws/lsphp81/lib64/php/modules/

$ echo "" >> /usr/local/lsws/lsphp81/etc/php.d/01-ioncube.ini

$ service lsws restart && service lscpd restart 

File error message.

I have edited that line please check again.

That path is for ubuntu distros only

I am using CentOs 7. Again the file error output.

Post the contents of ls /usr/local/lsws/lsphp81/

bin etc include lib64 man share tmp

Post the contents of ls /usr/local/lsws/lsphp81/etc/

php.d php.ini php.ini.rpnew

Post the contents of ls /usr/local/lsws/lsphp81/etc/php.d/

Do you have 01-ioncube.ini in that list?

If you do rUn

echo "" >> usr/local/lsws/lsphp81/etc/php.d/01-ioncube.ini 

No 01-ioncube.ini does not exist.


$ cd ~ && cp --verbose ioncube/ /usr/local/lsws/lsphp81/lib64/php/modules/

1 Like