CyberPanel Backups v2 Proposal

Do you have any idea that why this exclude command is not actually working?

Logs folder still being backed up.

@usmannasir if you want to exclude all rusticbackup and logs folders, you should use the --glob option: --glob !rusticbackup --glob !logs. You may need some escaping or wrapping the pattern in quotes depending on how the command execution work.

The --exclude-if-present option ignores a path if it contains a file/dir with that specific name. It can be used e.g. to exclude cache dirs (using --exclude-if-present CACHEDIR.TAG) or to allow users to mark dirs not-to-backup by using --exclude-if-present .nobackup in the backup command and let users create themselves a .nobackup file in those dirs.

logs and rusctic backup are present in {source} and I only wanted to exclude those specifi folders at {source}, do I need to give absolute path ?

Yes. If you don’t specify it as absolute path, every path with that name will be excluded.

I think this should do: bug fix in exclude · usmannasir/cyberpanel@f4ba445 · GitHub

You should use something like --glob "!{source}/logs". With --exclude-if-present your whole {source} dir will be excluded as within a directory named logs exists.

This should do bug fix in exclude · usmannasir/cyberpanel@950fcca · GitHub

mysqldump --defaults-extra-file=/home/cyberpanel/.my.cnf -u root --host=localhost --port 3306 --add-drop-table --allow-keywords --complete-insert --quote-names --skip-comments VTFs610I9oecK1 | sudo -u tests7889 rustic -r backup --stdin-filename VTFs610I9oecK1.sql - --password "" --json 2>/dev/null
WARNING: Forcing protocol to  TCP  due to option specification. Please explicitly state intended protocol.

any idea why this warning is getting generated?

1 Like

seems to be a mysqldump message. Google found WARNING: Forcing protocol to TCP due to option specification. Please explicitly state intended protocol. · Issue #56 · sixhop/AutoMySQLBackup · GitHub

1 Like

This is what ChatGPT thinks >>>

The warning message is generated because the command is using the “localhost” value for the --host option, but not specifying the protocol for the MySQL connection.

By default, the MySQL client will use the Unix socket protocol to connect to the MySQL server if the host is “localhost”. However, when specifying the “–port” option, the MySQL client will default to using the TCP protocol, which requires a network connection.

To avoid this warning message, you should explicitly specify the protocol to use for the MySQL connection by adding the “–protocol=TCP” option to the command.

For example:

mysqldump --defaults-extra-file=/home/cyberpanel/.my.cnf -u root --host=localhost --protocol=TCP --port 3306 --add-drop-table --allow-keywords --complete-insert --quote-names --skip-comments VTFs610I9oecK1 | sudo -u tests7889 rustic -r backup --stdin-filename VTFs610I9oecK1.sql - --password "" --json 2>/dev/null

This should ensure that the intended protocol is used for the MySQL connection, and prevent the warning message from being generated.

Yes just fixed this issue.

1 Like

Sorry I still didn’t understand so Hetzner storageBox works now? Which we need to use?

Access with SAMBA/CIFS - Hetzner Docs

Im using contabo object storage(S3)
I saw that still is not supported:

Will first initiate backup repo..
Fatal: create repository at failed: client.BucketExists: The AWS Access Key Id you provided does not exist in our records.

Repo initiated for
Meta data is ready..
Backing up databases..
Fatal: unable to open config file: Stat: The AWS Access Key Id you provided does not exist in our records.
Is there a repository at the following location?
. [5009].

Do we have a time shecdude when will be supported?

I’ve been using cyberpanel but I’m having problems with the scheduled incremental backup.

CentOS 7 64-bit with CyberPanel (hostinger)

Whenever it runs, my server uses a LOT of CPU and stays that way forever until I reboot.

I would like to understand the reason for this problem and try to fix it.

Some prints below for better understanding:




@usmannasir hello, how are you? can u help-me?

1 Like

@usmannasir We need a one click full backup option.

And when I say Full I mean everything, including: The cyberpanel users, ACLs, Packages, all of the websites and their configs, docker and everything to do with it, literally everything.

So that we can backup the entire cyberpanel server data into one singular file. This is especially useful when upgrading the OS. As currently, we have to make a seperate backup per website, then restore each one seperately after re-installing the OS and cyberpanel, then manually having to re-create each user, each ACL, each package, and manually assign the websites to the correct users and ACLs, manually re-create all of the docker containers. It is an absolute nightmare!

Being able to back all of this up into one file with a few clicks, and being able to restore everything from that single file would solve this. Many panels already do this, and it’s the one feature I genuinely always wished cyberpanel had. I got super excited when I saw backupsv2 pop up after updating cyberpanel, as I thought this finally brought this functionality, only to be disappointed.

1 Like

They are asking for 139 dollars for all the plugins, but in my opinion, and I believe many others share this view, I would willingly pay DOUBLE if I had something that actually worked and was not full of bugs or incompatibilities. For instance:

  1. For the schedule remotely backup, I want to connect it to the Contabo object storage, which has been incompatible for quite some time now.
  2. WordPress Manager: Coming from a similar plugin in Plesk, I assure you it is NO comparison. Essential features are missing, they could simply copy the innovations from the very successful Plesk plugin. This one has no comparison and I can detail those things that it doesn’t have or those that are not working.
  3. SSL: I have my CyberPanel as a subdomain and for some time now, the SSL has been broken and doesn’t seem to get fixed, regardless of any changes I make.
  4. Unfriendly CyberPanel update system: It could be done with a simple button, instead of saying that the git code differs from the stable version… And many others.

So, I can assure you that if you fix these two crucial things, I would pay double for the one-time purchase…


I agree. I bought the plugins too, but wished it just works.

My feedback would be: test test test! Test every feature thorough. Nothing really works out of the box. I prefer less features that just work or indeed - double the price - as long as it works. I’m sure the community can help in beta testing features. Every promise that isn’t met is a dissapointment. People can have a few, but will end up walking away. Backups v2: doesn’t work for me. I need to figure out now what this means: [06.02.2023_10-21-03:FAILED] Failed during config generation, Error: Expecting value: line 1 column 1 (char 0)[404]. That’s after the issue I had with not being able to setup FTP accounts.

Still enthusiastic and really see lots of potential. But please, give the user experience and the usertests more attention. I have now 3 backup features in my CP. None really usable so far.

Perhaps the community can help. Ask me for a feature to test: I’ll record it while using it and you can see what I’m running into. You have users and a community.

I hope to have kept it a bit constructive. :slight_smile: All the best. Life is a learning curve.


There are so many things wrong with CyberPanel right now. A user who is not an admin should not see certain things. As with all the addons that the admin does not subscribe to, this is very awkward and will force me to have a change of mind before some high-profile customers start moving their websites to my server. Something should be ddone ASAP or provide the ability to hide them.

1 Like