Wordpress: Installation failed. Error message: [404]

For me didnt worked … i am on AWS i tried to follow both solutions… For me it sounds really annoing and a bit stupid to dont do tests of functionalities before launching updates … This thing with personal compiled php versions that dont allow us to install wordpress it`s denotes alot of unprofessionalism… If i were a programmer and i had compiled php to suit my needs, then for sure i would check if all the apps will work with it … in all platforms , and if not working, i would try to also compile the apps to suit my needs too…

1 Like

For mine, I found out the website hit the limit of the number of databases for the package so the database was not created whenever WordPress tried to install.

I increased the number of databases allowed for the package and it worked.

it seems that wordpress can’t establish a connection to database
for most this command should work without any reboot.
apt-get install php-mysql

if this didn’t work, you should post your error-logs and debug as mintioned in the docs : Troubleshooting CyberPanel - CyberPanel
so other users can help you

1 Like

Thank you Josh.
You save my Day.

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.

apt-get install php-mysql didn’t work for me. I upgraded cyberpanel and everything worked again. 02 - Upgrading CyberPanel - Docs / 01 - Install/Upgrade - CyberPanel Community. I hope this helps some people.

1 Like

This won’t do anything as CyberPanel use lsphp

1 Like

So what is the correct solution here? Upgrade cyberpanel like I did?

I can’t see much info in original post, but sometimes its wp-cli not installed or problem with lsphp cli.