Restore Remote Incremental Backups - Could not connect to server, please refresh this page

Hello, I have a new install of cyberpanel and I am trying to restore a website that was backed-up to S3 from another cyberpanel server.

When entering the credentials, I am getting a “Could not connect to server, please refresh this page” error. What might be causing the error?

I think it’s just source or destination Firewall block port error … please check Firewall Log

Have you tried to take out s3: out from front of address? Now it show… looks weird to me that s3: on front

1 Like

@Dreamer I agree it looks weird, but actually the s3:s3… is added by cyberpanel. I just enter the AWS access key id and secret access key

Hello everone. I haven’t been able to get this fixed, I have tried everything! I re-installed cyberpanel, changed AWS keys, disabled all firewalls… and nothing worked.

The strange thing is that I can actually create a backup and the backup does appear in AWS S3, so the server is able to communicate with AWS. The problem is when I try to restore from remote, that is when the error appears.

I just tried the following: I re-installed cyberpanel with a previous version (v2.1.1) and it worked perfectly, I was able to both create a backup and restore it from AWS. I then upgraded cyberpanel to v2.1.2 and the problem returned, I am no longer to restore.

Could this be a bug in v2.1.2? @usmannasir

Not really optimal solution but maybe try UpdraftPlus I use it for SFTP backup location because cyperpanel option just not work what ever I try…

Would you help in providing more detail at the github branch as BUG for the developers to take a look and solve it at priority?