My email setup is not working properly

I have created an email address and added the DNS in the right way. But the emails are not sent and bouncing even on the test. However, if I can receive the emails on the created email fine, the issue is only with the sending.

Hello @kiltzone66058 Happy you are here

You will need to check if you issued mailserver ssl. Go to SSL → Mailserver SSL → choose your mailserver domain and issue SSL

I have done that already and fixed the error related to it as well.

You still cannot send email?

Yes, I can’t! Although I can receive emails just fine, but when I send them they don’t lend in my destination emails and no error on the sender email as well.

Check the mail queue are they deferred or blocked - https://SERVER_URL:8090/emailPremium/mailQueue

It is is showing deffered

Acceptance of your emails is delayed do you mind telling us who the destination’s email provider is? GMail?

yes the destination email is Gmail.

Ok just to be sure run this test using your cyberpanel email address - //email/testTo: you can add extra options to give us a clearer picture

Post a screenshot here of the results. You can hide any sensitive info you dont want us to view.

Remove links in your email body if you have any GMail is meticulous about that because of Bulk Sender’s Guidelines

Post the email logs here https://SERVER_URL:8090/serverlogs/errorLogs

Did you get my email?

No post the contents of nano /etc/postfix/ || vi /etc/postfix/ by running said command on ssh terminal

For Ubuntu nano /etc/postfix/

For RHEL based vi /etc/postfix/

conf IS OK

Post this here

Seen the correct logs in your DM

Edit nano /etc/postfix/ and change

inet_protocols = all


inet_protocols = ipv4

and have these directives as such

smtpd_milters = inet:
non_smtpd_milters = $smtpd_milters
milter_default_action = accept

Probably milter service is either is not started or not working properly. But I highly doudbt that. Also maybe dns

Edit “nano /etc/resolv.conf” and try:





service postfix restart && service postfix status

Post screenshot of result

You can check this docs to understand why

Have I done it right? (Little weak on SSH stuffs

Everything is ok. Try sending an email to me and to that gmail account

I tried and it didn’t work for me and sent you too.

Me neither. I will assume you have not done the basics. Kindly check the firewall https://SERVER_URL/firewall/ do you see rule smtp with port 25 and smtps with port 587?

Do you have any other firewall? Which service provider do you use?