Issues after upgrading to build 1.8 version 5

Upgraded from version 1.8 build 4 to version 1.8 build 5. But there’s some issues,

  1. Still that “Invalid SSL” persists
  2. “admin” user “First” and “Last” name has vanished!
  3. “Server IP Address” also vanished!
  4. Although I don’t use “PowerDNS” but going to “panel/manageservices/managePowerDNS” shows “Error message: (1054, “Unknown column ‘masterServer’ in ‘field list’”)”

I will update this post if I find more issues ASAP!

:8090/serverstatus/services

error: Could not connect to server. Please refresh this page.

powerdns
journalctl -f | grep pdns

error: Could not retrieve security status update for ‘4.1.1-1.Ubuntu’ on ‘auth-4.1.1-1.Ubuntu.security-status.secpoll.powerdns.com.’, RCODE = Non-Existent domain

Please let me know when all these issues are fixed because I am experiencing them as well after I upgraded.

Please let me know when all these issues are fixed because I am experiencing them as well after I upgraded.

Sure! Lets hope these issues gets fixed ASAP! :disappointed:

ubuntu or centos ?

@Altunkurt said:
ubuntu or centos ?

CentOS

CentOs is fixed now, you just need to run the upgrade as listed here

If using Ubuntu do the same as above, then run Ubuntu update. (apt-get update && apt-get upgrade) if services are still not working.

Worked for two installations of mine. Ubuntu did not work until new updates got added

@bsanz16 said:
CentOs is fixed now, you just need to run the upgrade as listed here
Upgrading CyberPanel - CyberPanel

If using Ubuntu do the same as above, then run Ubuntu update. (apt-get update && apt-get upgrade) if services are still not working.

Worked for two installations of mine. Ubuntu did not work until new updates got added

Is it really fixed? I know the update part, been using CyberPanel for 1+ years. Then again why CyberPanel team didn’t post an update about it if it’s really fixed? Let’s try upgrading and see what happens.

@bsanz16 just upgraded it again. Nothing is fixed. 1-4 all probs are there.

Are you on centos or ubuntu?

@bsanz16 said:
Are you on centos or ubuntu?

CentOS

try run yum update, my centos worked straight away once updated again on 1.8.5
Ubuntu I downgraded to 1.8.4 then upgrade to 1.8.5 then 1.8.5 again after service status got fixed

See this thread for note about fixed, 3 up from bottom

check powerdns version, it should be 4.2 on 1.8.5 It may not have been updated even though you do not use

run this in ssh

pdns_control version

@bsanz16 bro! All of my services are okay! I can restart or pause any service through panel! My only issues are these,

  1. Still that “Invalid SSL” persists
  2. “admin” user “First” and “Last” name has vanished!
  3. “Server IP Address” also vanished!
  4. Although I don’t use “PowerDNS” but going to “panel/manageservices/managePowerDNS” shows “Error message: (1054, “Unknown column ‘masterServer’ in ‘field list’”)”

@bsanz16 and yes pdns version is 4.2

@bsanz16 also to clarify more, all of my websites are working and all are up. Just those issues are my only concern that’s all.

if you didn’t try it update mysql/mariadb that is all I can think of.

@bsanz16 all of my system software is up to date. I update CentOS 3-5 times a day. No software is outdated. Also I use MariaDB 10.3

@bsanz16 if it helps to narrow down the issue, I use dedicated server, no VPS/ VDS etc.

@bsanz16 if I am not wrong, issue 1-3 is more likely a “typo”. For issue 4 that is another case. @CyberPanel needs to dig more to gain what that issue is. Who knows maybe that’s also a “typo” sort of issue or any integration related issue.