Hostname SSL Not Working? Or Am I doing it wrong?

Installed Cyberpanel fresh. Everything is working and I can access the panel via IP:8090.

Also, I added A record from Cloudflare to my server IP for mywebsite.com.

I wanted to access the panel via hostname. So I created a new website as panel.mywebsite.com first. Then issued SSL for hostname for the same domain panel.mywebsite.com - everything worked.

Restarted Litespeed too. Now when I go to panel.mywebsite.com I can see the OpenLiteSpeed page but panel.mywebsite.com:8090 returns nothing.

Am I doing it wrong?

I am describing my workflow again.

Suppose my domain is mywebsite.com

  1. Logged into Cyberpanel - added website - panel.mywebsite.com (with SSL +DKIM + Open directory
  2. Go to SSL - > Hostname SSL → Select panel.mywebsite.com → Generate SSL (Successful)

On Cloudflare end,
Added A record for mywebsite.com - like this https://i.imgur.com/TtwgOsT.png

1 Like

I think you want something like this → How to remove port 8090 from CyberPanel - CyberPanel

no. I am okay if I can access the panel using panel.mywebsite.com:8090 - but unfortunately that’s not working too! I can only access using the IP

You need to turn of CloudFlare proxy for panel subdomain, it won’t allow port 8090.

Thanks so much. It worked.

You can add this info on this page - 2 - CyberPanel on SSL - CyberPanel so that other’s don’t face it :smiley:

I can´t change to SSL and still use 8090 port, is that possible? I followed instructions on 2 - CyberPanel on SSL - CyberPanel and SSL certificate is created but still 8090 is under non-SSL

I am locked out from CyberPanel - OMG !!!

  1. I issue an sslForHostName
  2. My domain is on Cloudflare
  3. When I access the IP:8090 It not working same for the domain:8090

WHAT TO DO?