Filtering Spam in RainLoop, AutoReply and Email Filters with Sieve

What? I see it, right it’s in the log, dovecot is saying : Fatal: Error in configuration file blabla line 80 … length

What is the full error, we can’t just debug this on “…length”, you cropped that screenshot.

I took the time to send a screenshot of it, I don’t want the config, or that you think it’s right, just the full error message that dovecot printed out. It’s logged somewhere anyway, nothing else matters, dovecot will never start if it has a Fatal Error

I just ran this dovocot error log checker.

doveadm log find

doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 80: Unknown setting: managesieve_max_line_length

good, progress.

So I don’t know, install dovecot-pigeonhole? Not sure where managesieve belongs to.

Tried this, and get an error.
Not sure why it’s in conflict.

## Install dovecot-pigeonhole on AlmaLinux 8 Using dnf

Update yum database with `dnf` using the following command.

sudo dnf makecache --refresh


After updating yum database, We can install `dovecot-pigeonhole` using `dnf` by running the following command:

sudo dnf -y install dovecot-pigeonhole


## Install dovecot-pigeonhole on AlmaLinux 8 Using yum

Update yum database with `yum` using the following command.

sudo yum makecache --refresh


After updating yum database, We can install `dovecot-pigeonhole` using `yum` by running the following command:

sudo yum -y install dovecot-pigeonhole

Did not run the uninstaller.


## How To Uninstall dovecot-pigeonhole on AlmaLinux 8

To uninstall only the `dovecot-pigeonhole` package we can use the following command:

sudo dnf remove dovecot-pigeonhole

that makes sense because dovecot comes with it and those sieve are version specific to dovecot

So remove that line? Does it continue complaining? I’d be surprised that almalinux dovecot is completely broken. what does journalctl -f | grep dovecot says? Any issue loading libraries?

Doing journalctl -f | grep
Outputs nothing.
I pressed enter a few times, but nothing shows.


yeah that’s normal because -f is to follow, like you send that to the background and launch dovecot…

anyway just remove lines in the config until you get some errors that makes sense. yum reinstall dovecot? yum -y install dovecot-pigeonhole dovecot-mysql? Just look on the internet, try stuff. My dovecot isn’t broken so can’t really help.

Hello everyone.

On Centos 7, clean installation with latest Cyberpanel this tutorial doesn’t even make it to Step 1.

Anyone got any new instructions?

Followed EVERY single suggestion on this post, on other posts, and on the internet also.

The most crucial question is: Has ANYONE implemented the above on the latest Cyberpanel and latest Openlitespeed (downloaded today?). Does ANYONE on this community have implemented sieve management and sents their spam mail into their Junk folder right now as we speak? Instructions like “Do this obvious thing”, or “Why don’t you try that” are no use if the commenter have NOT implemented this in your devices successfully also.

It seems weird that all around the internet there is no proper instruction for this. Everyone is giving false or limited instructions. As a company, we had to outsource it and post a Job Request on the famous sites, because it’s been over a month that we try to implement it without any luck.

Best regards!

Oh right, I never solved that thing since I was so pissed off at that guy who refused to post his error, I hate those people.

Anyway, that problem was solved by this guy on centos 7 : HELP me: Email not receiveing after setting up filtering spam in rainLoop - #17 by 73Hn

Which is you have to add dovecot repo at since the centos 7 repo has conflicting dovecot and dovecot-pigeonhole packages and you’ll never be able to install matching dovecot/pigeonhole otherwise, the two has to match, or it won’t work. My solution of just installing pigeonhole was always the solution, just you need to add the dovecot repo.

Hopefully the outsource to famous sites wasn’t too expensive!

1 Like

Damn I never seen people that need so much handholding

If you want to use ghettoforge ( what cyberpanel use )

yum --enablerepo=gf-plus -y install dovecot23-pigeonhole

for the official repo, after adding the dovecot repo

yum remove dovecot23 dovecot23-mysql
yum install dovecot dovecot-mysql dovecot-pigeonhole

the dovecot.conf will be dovecot.confrpmsave or something similar, or just copy one in this thread.

1 Like

Is this forum purpose is ask help from community? Or did I get something wrong…

1 Like

Yeah I’ve been thinking about it, it’s mostly because I disagree with the ghettoforge path, I feel it’ll just repeat itself next security update versus the official repo, it’s the state of centos repo, try to find a yum repo for imagick for lsphp. So naturally, I prefer to answer other path, until I get 10+ dm of endless text from people adamant they’ll never ever try official repos, then I give up.

It’s like your solution to OWASP issues "This domain does not exists" error - #10 by Dreamer which is “disable 949-BLOCKING-EVALUATION”, this remove any blocking and evaluation, makes the whole ruleset useless. It’s useful in a way, like you can fix any firewall issues if you just open all the ports. This is appalling to me, but I guess super useful if you don’t know.

What is your point to even be here?
To be arrogant, rude, try make people feel idiot whith your god tier knowledge?
You don’t need to be arrogant when helping people on forums, if you get annoyed from people asking maybe better not even try

Exactly the question I ask you, what you contribute to this discussion? Are you having an issue with sieve? Something to contribute to fix the problem? I answered everything and fixed the issue, I think I can be frustrated when people refuse to send their errors or even try to install a package themselves and instead send me endless messages non technical message like you do

So sorry if I hurt your feelings. :cry:

Yeah we know you have no solution, or nothing to contribute to the discussion, some might say you just join to complain about me… almost attack…

Like I mentioned, I don’t like the solution, because to remind you, I found the solution. I think it’s better to move to official repo than expecting ghettoforge long term to not mess up, but people disagree, so I presented both solution ( after much DM and much pushing because people apparently hate dovecot official repo ), let people pick. It’s like I disagree to your solution that any OWASP issues can be fixed by removing the one file that actually do any rejecting making the whole thing useless, but it works, just like removing reject in firewalls. It’s related to the solution. I personally don’t care how people run their server, or if they listen to you, more money for me when things breaks! Maybe next time I’ll be inspired by you and just teach people to downgrade, it used to work!

You are “bragging” and complaining in the same post.

You brag that you found a solution that does NOT work.

You also complain about people posting blurred/painted-over photos, where NOTHING was capped out of the image, except for unneeded commands done over the line posted.

damn the drama on this thread…

What doesn’t work about it? Like mentioned many times, you need to install dovecot-pigeonhole to go over your error message it was so secretive I had to ask many time for you to send it. I did the whole handholding since “install dovecot-pigeonhole” was too cryptic.

Either ghettoforge or official dovecot, up to you.

For CentOS 8 and AlmaLinux, the correct way is actually yum install --enablerepo=gf-plus dovecot23-pigeonhole -y.