Errors during downloading metadata for repository 'powertools-for-cyberpanel':

#ASK #HELP
please help me :
error :
yum update
CentOS Linux 8 - PowerTools 0.0 B/s | 0 B 00:00
Errors during downloading metadata for repository ‘powertools-for-cyberpanel’:

Please check server Nameservers

No problem on ns

is there any other solution?

It seems almalinux disappeared from mirror.centos.org.

I’ve changed this line in the repo file:
baseurl=http://mirror.centos.org/$contentdir/$releasever/PowerTools/$basearch/os/
to
baseurl=http://mirror.centos.org/centos/8-stream/PowerTools/x86_64/os/

But another issue came up:
Error:
Problem: cannot install the best update candidate for package libmemcached-devel-1.0.18-15.el8.x86_64

  • nothing provides libmemcached(x86-64) = 1.0.18-17.el8 needed by libmemcached-devel-1.0.18-17.el8.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

Please run cyberpanel upgrade command, the broken repo has been fixed now.

is there any other solution?

not working sir…

I see that its been fixed recently: https://github.com/usmannasir/cyberpanel/commit/b5b4e436bd973ea15573c74d87b8933b772ce2f5

You can comment there providing your outputs so that it will help the developer identify the case and fix the repo links of centos

how to run this command ?

Execute this command first

sudo su -

And then run this upgrade command

sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)

hello sir. i have tried this command.

result :


Are you using Almalinux?

im using

# cat /etc/centos-release

CentOS Linux release 8.5.2111

please help me

I have simillar issue but try to install in ubuntu 18.04/20.04 and centos 7
I tought the blocked my IP address but it shows me the installer and scripts have problems
I cheek the install.sh and changed something and uesd echo command and tried to install package manually , but after each one again I faced with new error …

same issue here
i run the upgrade command but still nothing
i have the latest CyberPanel on AlmaLinux release 8.5 (Arctic Sphynx)

any solutions ?

any solutions ?

please help me …

Its been already looked upon https://github.com/usmannasir/cyberpanel/commit/b5b4e436bd973ea15573c74d87b8933b772ce2f5

how to run this command ?

like this ???

sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)

Yes, exactly copy paste this command and press enter in the ssh console.

hello sir …
not work

any solutions ?

please help me …

Result :
run this commandline :

sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)


on proses


finish


same issue :frowning: