Error when updating CyberPanel


I’m trying to update CyberPanel and the command is the same as given here:
See the errors that occur at the end of the print!!

I try:

sh <(curl || wget -O -


1 Like

It ends up giving an error at the end!


Hello @lucasromeiro Happy you are here

I always tell my clients to avoid Centos and RockyLinux when it comes to CyberPanel. Use AlmaLinux 8.4 instead. I know this is not a solution but I have never seen anyone running centos here get a solution with any issue for the last 2 months.

Hello, thanks for the reply.
My server only provides me with the image of CENTOS with CyberPanel. There are other versions but none with CyberPanel. What do you recommend?

Hello buddy choose the images with clean os no cyberpanel. Prefer Ubuntu 20.04LTS X64

Then install cyberpanel by using ssh terminal and run this command

$ sh <(curl || wget -O -

Hi, nice.
But i have only this options:


What is the best choice?

UBuntu 20.04 64bit. If this is hostinger always go with that.

NICE!! I Will try this now.
after installing, how do i open the panel?

https://<your server’s IP address>:8090

I receive one error:


I tried again and the error remains the same.
What should I do?

Can u help me?

Sidenote i do not recommend hostinger for any use at all. However, can you try this copy to see if it installs

sh <(curl || wget -O -

Hi Joseph,

I chose hostinger because it won the award for the best cost-benefit VPS in 2022.
Why not recommend them?

With cyberpanel it doesn work as expected because they have software or setups behind the os that prevent you from actually using the os as yours.

From experience I have never been able to setup a cyberpanel vps preinstalled properly there is always an issue


What is your recomendation? Cost x benefit.

The instalation freeze here. 1 hour…


SOmething is stopping it from proceeding probably some firewall by hostinger, cause I just setup a server for a client now and all went well. Ask hostinger support

I also tried to use your version, same as @lucasromeiro, but the installation freezed as well.
From the original version of from yours, there are some differences on the code allowed (“normal”)?

I’m asking that because that’s my first time trying to setup a panel on Ubuntu, and I am also using Hostinger with Ubuntu 20.04 64bit. I also had the same error as before, but seems like nobody have a solution for it and I didn’t find anything online as well.

Which service provider are you using?

Hostinger. I was trying to create the panel using a VPS with Ubuntu 20.04 64bit.