Email Login Problem with Rainloop/Dovecot

Hello Everyone

Lately we’ve seen that there were lots of reports about email problem with Rainloop.

In CyberPanel version v1.8.5 and above we are using CRYPT format for email passwords. Which requires an upgrade in the Dovecot version.

Dovecot was upgraded in the upgrade process but due to plugin priorities upgrade did not went through for some users.

We’ve taken care of this issue in the upgrade and install process for future, however you can manually solve this issue by running this commands:

yum remove yum-plugin-priorities -y

Or open /etc/yum/pluginconf.d/priorities.conf and set enabled to 0.

Then open etc/yum.repos.d/dovecot.repo

and paste

name=Dovecot 2.3 CentOS $releasever - $basearch

Finally upgrade dovecot

yum makecache -y
yum update -y

In case you can’t get into Rainloop, try changing password for your emails.

These days we’ve received countless tickets and Facebook messages due to which we could not react in timely manner for all queries.

In case your issue is still not resolved you can reach us via helpdesk/forums. For bug reports do not use our Facebook group or live chat.

Sorry for any inconvenience caused.

I confirm that the combination of the first command and the last two commands solved my problem.

Many thanks for your competent help!

I confirm that the combination of the first command and the last two commands solved my problem.

Many thanks for your competent help!

Can you confirm the commands?

I recently update to the latest version now cannot login to webmail.

‘yum remove yum-plugin-priorities -y’ shows for me the following:

‘yum remove yum-plugin-priorities -y
Loaded plugins: fastestmirror
No Match for argument: yum-plugin-priorities
No Packages marked for removal’


You can then continue with further steps.

@CyberPanel said:

You can then continue with further steps.

I’ve done all that and still the same.

I did notice during latest update however that I saw a message saying grub2 tools or something is duplicated.


You can’t login to Rainloop ? Can you grab the message from journalctl -f | grep dovecot

Capture the output when you try to log in to Rainloop.

As noted in my ticket, my emails still do not work and I was already on Dovecot 2.3.

Ticket id @Hifihedgehog ?

@CyberPanel said:
Ticket id @Hifihedgehog ?



There is another issue now too which appears to be with the Let’s Encrypt SSL certificates no longer automatically refreshing. Please fix!


Kindly don’t use this thread for multiple issues.

However Lets Encrypt renew failure can be due to many other reasons.

Force redirect, application configured to use https etc.

Respectfully, there are many errors and much damage that these hastily released updates caused. I already noted in my ticket that I do not have the database tools to restore the passwords that your upgrade script had corrupted. In an effort to give you a chance to mend this situation, I have invited you and invite you again to fix your mistake starting with me. I understand it represents a lot of work, but I have been contributing to this community and I would welcome some reciprocation for it. I can even gladly donate some money for your time even but all I ask is your help. Thanks!

Plus, as mentioned earlier, email passwords need to have a $ character in them in some cases. Has this been fixed and if so, is it safe to rerun the CyberPanel upgrade script to apply the fix?



No doubt you have contributions, but you do have to understand our contributions to the community as well.

Helping all our free users either via helpdesk or forums. Right now there is so much to do, that is why things are bit slow, but all the tickets and threads are pretty much answered along with bug fixes.

Totally understandable. Coming from a more traditional, business developer background, though, I have learned earlier on that whenever changes are introduced and proper validation is not guaranteed, I am the sole party who is responsible and culpable if I rushed a feature out which caused damage to the user’s data and configuration. I understand how many hours of unpaid work your current development paradigm has invested but that unfortunately still does not preclude you for the responsibility of proper validation and taking responsibility and recovering when the onus is on yourself, no matter how painful and time-consuming it is. It is a painful lesson in the school of hard knocks, to be sure, but everyone has to learn it early on or no one will take them seriously or trust in their work. Otherwise, if users see their data as written off as a casualty even when they have backups or other means that you could effectively restore or provide tools to restore, it sends the clear signal that you do not take their data seriously. Some solutions to avoid this pitfall include not being reactionary in tense critical security-related situations like this one and instead being proactive in order to avoid collateral damage and negative feedback. Just some food for thought.


Agreed and lesson learned. Though responded your ticket regarding how you can generate the password in crypt format through PHP.


Agreed and lesson learned. Though responded your ticket regarding how you can generate the password in crypt format through PHP.

I did! And not only that, but I also just finished a full, custom CyberPanel password changing plugin for Rainloop! :smiley: I will be uploading it very soon now!

Done and done. I also initiated a pull request. So hopefully, it should be added very soon to the official Rainloop project. If this meets your approval team @CyberPanel, please let the Rainloop team know that they can go ahead and add it: