CyberPanel Ubuntu Bug Reports

Hello

Please use this thread to report any issues on CyberPanel Ubuntu.

Regards

hi, i’m trying to install cyberpanel but i can’t download the installer because curl is returning error 77: error setting certificate

Are you trying to install Ubuntu Beta, the guide is here https://cyberpanel.net/2018/11/19/cyberpanel-now-supports-ubuntu-18-04-and-18-10/

and should be run as root (not sudo)

yes, i’m trying to install the Ubuntu Beta. it has the same problem when trying execute that command on that guide returning curl: (77) error setting certificate verify locations

Could you please paste full terminal ? since you start to run that command and until end of it where you see error.

just tested it in a vm on my local machine and it works fine on there so it’s the initial server that has problems running ubuntu.

Install IonCube loader on CyberPanel Ubuntu ???

ftp, spamav and firewall dosnt work… ubuntu 18.04 :confused:

ftp, spamav and firewall dosnt work.. ubuntu 18.04 :/

Please use bug report template Bug Report Template — CyberPanel - WebHosting Control Panel for OpenLiteSpeed

Hi,

If you have a problem or possible bug and seek for help, please:

  1. please using following example:

Provider: Vultr, local computer

System: Ubuntu 16.04 , Ubuntu 18.04

Installation option: since during the installation.
there will be few option to choose,so please provide it as well.

OLS or Enterprise?
OLS

Installing from official server or mirror server?
official

Replace JS/CSS files to JS Delivr?
no

Problem:

Traceback (most recent call last):
File “install.py”, line 3581, in
main()
File “install.py”, line 3517, in main
installCyberPanel.Main(cwd, mysql, distro, ent)
File “/home/teknisi/install/installCyberPanel.py”, line 768, in Main
installer.installAllPHPVersions()
File “/home/teknisi/install/installCyberPanel.py”, line 226, in installAllPHPVersions
1, 1, os.EX_OSERR)
File “/home/teknisi/install/install.py”, line 69, in call
res = subprocess.call(shlex.split(command))
File “/usr/lib/python2.7/subprocess.py”, line 172, in call
return Popen(*popenargs, **kwargs).wait()
File “/usr/lib/python2.7/subprocess.py”, line 394, in init
errread, errwrite)
File “/usr/lib/python2.7/subprocess.py”, line 1047, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory

Something went wrong…

Best regards,

Traceback (most recent call last): File "install.py", line 3581, in main() File "install.py", line 3517, in main installCyberPanel.Main(cwd, mysql, distro, ent) File "/home/teknisi/install/installCyberPanel.py", line 768, in Main installer.installAllPHPVersions() File "/home/teknisi/install/installCyberPanel.py", line 226, in installAllPHPVersions 1, 1, os.EX_OSERR) File "/home/teknisi/install/install.py", line 69, in call res = subprocess.call(shlex.split(command)) File "/usr/lib/python2.7/subprocess.py", line 172, in call return Popen(*popenargs, **kwargs).wait() File "/usr/lib/python2.7/subprocess.py", line 394, in __init__ errread, errwrite) File "/usr/lib/python2.7/subprocess.py", line 1047, in _execute_child raise child_exception OSError: [Errno 2] No such file or directory

Something went wrong…

Just got the same error. Ubuntu 18.10 x64… Vultr provider

For ubuntu please try official installer Installing CyberPanel - CyberPanel

is not that installer only for centos 7?

It will auto-detect your OS.

Thanks, It worked.

For ubuntu please try official installer https://cyberpanel.net/docs/installing-cyberpanel/

[11-19-04-Tue-Dec-2018] #########################################################################

[11-19-04-Tue-Dec-2018] MariaDB instance successfully enabled at system restart!

[11-19-04-Tue-Dec-2018] #########################################################################

[11-19-04-Tue-Dec-2018] #########################################################################

[11-19-04-Tue-Dec-2018] MYSQL Root Password change. [changeMYSQLRootPassword]

[11-19-04-Tue-Dec-2018] #########################################################################

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

[11-19-04-Tue-Dec-2018] #########################################################################

[11-19-04-Tue-Dec-2018] MYSQL Root Password change. failed, trying again, try number: 1

[11-19-04-Tue-Dec-2018] #########################################################################

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

[11-19-04-Tue-Dec-2018] #########################################################################

[11-19-04-Tue-Dec-2018] MYSQL Root Password change. failed, trying again, try number: 2

[11-19-04-Tue-Dec-2018] #########################################################################

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

[11-19-04-Tue-Dec-2018] #########################################################################

[11-19-04-Tue-Dec-2018] MYSQL Root Password change. failed, trying again, try number: 3

[11-19-04-Tue-Dec-2018] #########################################################################

[11-19-04-Tue-Dec-2018] #########################################################################

[11-19-04-Tue-Dec-2018] We are not able to MYSQL Root Password change. return code: 1. Fatal error, see /var/log/installLogs.txt for full details [changeMYSQLRootPassword]

[11-19-04-Tue-Dec-2018] #########################################################################

@katak please describe your env Bug Report Template — CyberPanel - WebHosting Control Panel for OpenLiteSpeed

Mod security installation failed https://prnt.sc/ltl23g

Mod security installation failed https://prnt.sc/ltl23g

Always provide as much details as possible, following the above format.

I didn’t install cyberpanel successfully on ubuntu 16.04 and 18.04 vps and localhost. I want to return to the previous configuration using openlitespeed but a lot of problems I found.
insserv: warning: current start runlevel (s) (2 3 5) of the LSB lsws' script defaults (2 3 4 5). insserv: warning: current stop runlevel (s) (0 1 2 3 5 6) of the LSB overrides lsws’ script defaults (0 1 6).
[OK] The startup script has been successfully installed!
Can’t determine the Home of LiteSpeed Web Server, exit!
[ERROR] Failed to start litespeed!
litespeed: no process found
Can’t determine the Home of LiteSpeed Web Server, exit!
[ERROR] Failed to start litespeed!

can anyone help solve my problem?