CyberPanel keeps creating a folder for a deleted website

I deleted a website long ago but a folder keeps being created for it at /home/, no matter how many times I delete it. The only thing that the folder contains is an empty public_html folder.

I have deleted all unused databases from mariadb, and searched the remaining ones for the wesbite name and didn’t find anything. I have deleted any extra system users as well.

What could be causing this?

Please share your cyberpanel version also go to the delete website and truly to do the deletion 2 3 times and then check

Latest version, but it has been happening for months. To clarify, it doesn’t show in Cyberpanel - it only creates the folder that I can see via the ssh cli. E.g cd /home ls. So there’s nothing to delete.

Hello, I have same issue, did you find any solution?

No, I never solved it. The deleted folder keeps coming back.

That looks like a fun thing to hunt and debug.

When you delete the website, how long does it take for the folder to re-appear?
Or the folder is recreated as soon as you delete it?
Or is a random time?
Or after a system restart?

Did you have ssl on the website?
Any automatic backup?

CyberPanel creating a folder for a deleted website - Support and Discussion / General Discussion - CyberPanel Community

same… because this is old one… i hope locked and focus on new post

Are you running any Docker containers with a bound volume? Could be that the container is recreating the folder, otherwise maybe a forgotten cronjob setting?

No Docker installed.

When you delete the website, how long does it take for the folder to re-appear?

  • It changes, sometimes one day sometimes 3-4 hours. It’s totally random. Not related with system restart or something like that.

Did you have ssl on the website?

  • Yes I have SSL on all websites.

Any automatic backup?

  • No auto backup opened.

Similar for me. Random time. Sometimes maybe minutes sometimes days. I don’t really monitor it.

I’m thinking perhaps it’s an ssl thing now that you mention it - there’s probably a cert still somewhere and it tries to recreate the folder when there’s some cron or other process to check/renew it.

But I have no idea how I’d debug such a thing.

I found something like that, I tried and I hope it works;

  1. connect to your SSH
  2. Type command below (don’t forget to replace your domain name)
    rm -rf /etc/letsencrypt/live/
  3. Hit enter

Nice one. I just did that and removed the /home/persistent-domain-name folder again as well - will have to wait to see if it persists!

@usmannasir There’s also many other domains that I deleted a while ago in /etc/letsencrypt/live. Should these not be deleted when you delete a website?

This didn’t work - the phantom website came back today at 00:07. However the folder in /etc/letsencrypt/live did not come back. Running find / -iname shows that the only folder/file is /home/

Try this to search inside all files:

grep -insr "" /*

Will take a long time. So try to limit it to specific folders, if doesn’t work then do a full search.

grep -insr "" /etc/*
grep -insr "" /usr/*
grep -insr "" /opt/*
grep -insr "" /home/*

I just ran this grep -rlw "" /* --exclude-dir={proc,tmp,mnt,bin,boot,opt,snap,srv,sys,run} instead so as to only print the filenames.


They mostly seem tobe log files. This one seems most suspicious/promising /usr/local/lsws/conf/httpd_config.conf0,v

I see the domain many times there, but not sure what is really happening in it. There’s also plenty of other previously-used domains listed in that file that are not having this problem

About the conf,v file, i noticed i also got old domains but no folder creation at home about them.

I thought it could be something on the cyberpanel scripts, perhaps some paths/crons that changed from an older version that were still running, but that would had to show there.

Perhaps one of those mysql’s has any config that cyberpanel fetches and uses at any cronjob/function?
But on the other hand, if older domains also exist there but don’t create folders then wouldn’t make sense.

Yeah, its a mystery. Evidently SOMETHING is creating it, but who knows what…

I did a search of all sql databases and didn’t find anything related to this domain…

You said it created at 00:07.

Can you delete the folder, and notice if it creates at 00.07 again?

Yeah i already deleted it. I just restarted the server and it wasn’t recreated, which is typical. I’ll have to check tomorrow/in the future to see what happens

Wait, i just noticed all of these files by doing find / -iname "**" - the wildcards returned more results that weren’t there with just find / -iname


I see no reason why those should still exist so will delete them and see what happens. Though, that folder contains lots of domains that aren’t currently in use…