Can send Mail But can't receive?

i set-up mail on Cyberpanel (Rainloop) and configured dkim and the rest on my cloudflare now the problem is i am able to send mail and can receive them on my test gmail acc… but cannot receive any emails on cyberpanel webmail if i send email for example from mail@mywebsite.com to mail@mywebsite.com then i can receive it.

Sorry, I did not understand, you mean you can’t send emails to your own domain?

@CyberPanel said:
Sorry, I did not understand, you mean you can’t send emails to your own domain?

Yes I can’t send emails to my domain mail which is configured through cyberpanel webmail

When you send internal email, capture output of ‘journalctl -f | grep postfix’

Aug 15 14:16:13 VPSERVER postfix/qmgr[15737]: EC1624C0394: from=pkreven@server.example.com, size=790, nrcpt=1 (queue active)
Aug 15 14:16:13 VPSSERVER postfix/qmgr[15737]: DC0194C038F: from=pkreven@server.example.com, size=679, nrcpt=1 (queue active)
Aug 15 14:16:13 VPSSERVER postfix/smtp[23524]: DC0194C038F: host gmail-smtp-in.l.google.com[108.177.15.26] said: 421-4.7.0 This message does not have authentication information or fails to pass 421-4.7.0 authentication checks. To best protect our users from spam, the 421-4.7.0 message has been blocked. Please visit 421-4.7.0 Prevent mail to Gmail users from being blocked or sent to spam - Gmail Help for more 421 4.7.0 information. g5-v6si16764287wrq.200 - gsmtp (in reply to end of DATA command)
Aug 15 14:16:13 VPSSERVERpostfix/smtp[23524]: connect to gmail-smtp-in.l.google.com[2a00:1450:400c:c0c::1a]:25: Network is unreachable
Aug 15 14:16:13 VPSSERVER postfix/smtp[23524]: connect to alt1.gmail-smtp-in.l.google.com[2a00:1450:4010:c0f::1b]:25: Network is unreachable
Aug 15 14:16:13 VPSSERVER postfix/smtp[23523]: EC1624C0394: host gmail-smtp-in.l.google.com[108.177.15.26] said: 421-4.7.0 This message does not have authentication information or fails to pass 421-4.7.0 authentication checks. To best protect our users from spam, the 421-4.7.0 message has been blocked. Please visit 421-4.7.0 Prevent mail to Gmail users from being blocked or sent to spam - Gmail Help for more 421 4.7.0 information. y87-v6si1592264wmh.27 - gsmtp (in reply to end of DATA command)
Aug 15 14:16:13 VPSERVER postfix/smtp[23523]: connect to gmail-smtp-in.l.google.com[2a00:1450:400c:c0c::1a]:25: Network is unreachable
Aug 15 14:16:13 VPSSERVER postfix/smtp[23523]: connect to alt1.gmail-smtp-in.l.google.com[2a00:1450:4010:c03::1b]:25: Network is unreachable
Aug 15 14:16:13 VPSERVER postfix/smtp[23524]: DC0194C038F: to=anotheremail@gmail.com, relay=alt1.gmail-smtp-in.l.google.com[209.85.233.27]:25, delay=403, delays=402/0.03/0.43/0.12, dsn=4.7.0, status=deferred (host alt1.gmail-smtp-in.l.google.com[209.85.233.27] said: 421-4.7.0 This message does not have authentication information or fails to pass 421-4.7.0 authentication checks. To best protect our users from spam, the 421-4.7.0 message has been blocked. Please visit 421-4.7.0 Prevent mail to Gmail users from being blocked or sent to spam - Gmail Help for more 421 4.7.0 information. g69-v6si11170790ljb.196 - gsmtp (in reply to end of DATA command))
Aug 15 14:16:13 VPSSERVER postfix/smtp[23523]: EC1624C0394: to=myemail@gmail.com, relay=alt1.gmail-smtp-in.l.google.com[209.85.233.27]:25, delay=403, delays=402/0.05/0.46/0.13, dsn=4.7.0, status=deferred (host alt1.gmail-smtp-in.l.google.com[209.85.233.27] said: 421-4.7.0 This message does not have authentication information or fails to pass 421-4.7.0 authentication checks. To best protect our users from spam, the 421-4.7.0 message has been blocked. Please visit 421-4.7.0 Prevent mail to Gmail users from being blocked or sent to spam - Gmail Help for more 421 4.7.0 information. 77-v6si10165542ljf.47 - gsmtp (in reply to end of DAT

It seems that all these messages are going to Gmail, and not domain on your server. You need to grep the output when you send email to your own domain (or where you are having problem sending email)

It seems that all these messages are going to Gmail, and not domain on your server. You need to grep the output when you send email to your own domain (or where you are having problem sending email)

the output is still same i sent mail to my domain where i can’t receive and yet the output is same

It seems that all these messages are going to Gmail, and not domain on your server. You need to grep the output when you send email to your own domain (or where you are having problem sending email)

the output is still same i sent mail to my domain where i can’t receive and yet the output is same

Which means your MX records are set to receive email at Gmail? Read these lines from your error logs

status=deferred (host alt1.gmail-smtp-in.l.google.com[209.85.233.27] said: 421-4.7.0 This message does not have authentication information or fails to pass 421-4.7.0 authentication checks. To best protect our users from spam, the 421-4.7.0 message has been blocked. 

Maybe I am not understanding your problem correctly, you need to describe exact use case with some good example.

It seems that all these messages are going to Gmail, and not domain on your server. You need to grep the output when you send email to your own domain (or where you are having problem sending email)

the output is still same i sent mail to my domain where i can’t receive and yet the output is same

Which means your MX records are set to receive email at Gmail? Read these lines from your error logs

status=deferred (host alt1.gmail-smtp-in.l.google.com[209.85.233.27] said: 421-4.7.0 This message does not have authentication information or fails to pass 421-4.7.0 authentication checks. To best protect our users from spam, the 421-4.7.0 message has been blocked. 

Maybe I am not understanding your problem correctly, you need to describe exact use case with some good example.

sorry was busy couldn’t reply

Mx record at gmail?
i haven’t set up anything like that not yet because i am using webmail (rainloop)

the problem:
when i sent email from gmail to mail@mywebsite.com > (rainloop cyberpanel) <>i can’t receive email here (cant recieve on mail@mywebsite.com which is rainloop cyberpanel) .
but when i send from my website to (from mail@mywebsite.com) > gmail then i can receive on gmail.

maybe i should open a ticket?

It seems that all these messages are going to Gmail, and not domain on your server. You need to grep the output when you send email to your own domain (or where you are having problem sending email)

the output is still same i sent mail to my domain where i can’t receive and yet the output is same

Which means your MX records are set to receive email at Gmail? Read these lines from your error logs

status=deferred (host alt1.gmail-smtp-in.l.google.com[209.85.233.27] said: 421-4.7.0 This message does not have authentication information or fails to pass 421-4.7.0 authentication checks. To best protect our users from spam, the 421-4.7.0 message has been blocked. 

Maybe I am not understanding your problem correctly, you need to describe exact use case with some good example.

sorry was busy couldn’t reply

Mx record at gmail?
i haven’t set up anything like that not yet because i am using webmail (rainloop)

the problem:
when i sent email from gmail to mail@mywebsite.com > (rainloop cyberpanel) <>i can’t receive email here (cant recieve on mail@mywebsite.com which is rainloop cyberpanel) .
but when i send from my website to (from mail@mywebsite.com) > gmail then i can receive on gmail.

maybe i should open a ticket?

When you send email from your server (in this case from Rainloop), your server just sends out your message by finding MX record of Gmail or any domain you are sending to. MX is a DNS record type that tells the world the location of the mail server for your domain.

You just need to set up MX record for your domain so that Gmail can find your mail server, for your reference https://support.cloudflare.com/hc/en-us/articles/218069617-How-do-I-add-or-edit-mail-or-MX-records-

It seems that all these messages are going to Gmail, and not domain on your server. You need to grep the output when you send email to your own domain (or where you are having problem sending email)

the output is still same i sent mail to my domain where i can’t receive and yet the output is same

Which means your MX records are set to receive email at Gmail? Read these lines from your error logs

status=deferred (host alt1.gmail-smtp-in.l.google.com[209.85.233.27] said: 421-4.7.0 This message does not have authentication information or fails to pass 421-4.7.0 authentication checks. To best protect our users from spam, the 421-4.7.0 message has been blocked. 

Maybe I am not understanding your problem correctly, you need to describe exact use case with some good example.

sorry was busy couldn’t reply

Mx record at gmail?
i haven’t set up anything like that not yet because i am using webmail (rainloop)

the problem:
when i sent email from gmail to mail@mywebsite.com > (rainloop cyberpanel) <>i can’t receive email here (cant recieve on mail@mywebsite.com which is rainloop cyberpanel) .
but when i send from my website to (from mail@mywebsite.com) > gmail then i can receive on gmail.

maybe i should open a ticket?

When you send email from your server (in this case from Rainloop), your server just sends out your message by finding MX record of Gmail or any domain you are sending to. MX is a DNS record type that tells the world the location of the mail server for your domain.

You just need to set up MX record for your domain so that Gmail can find your mail server, for your reference https://support.cloudflare.com/hc/en-us/articles/218069617-How-do-I-add-or-edit-mail-or-MX-records-

ok now i have added mx record in my cloudflare but still i can’t seem to receive mail and i am getting this error in cloudflare “An MX record was not found for your root domain. An MX record is required for mail to reach @website.com addresses.”

It seems that all these messages are going to Gmail, and not domain on your server. You need to grep the output when you send email to your own domain (or where you are having problem sending email)

the output is still same i sent mail to my domain where i can’t receive and yet the output is same

Which means your MX records are set to receive email at Gmail? Read these lines from your error logs

status=deferred (host alt1.gmail-smtp-in.l.google.com[209.85.233.27] said: 421-4.7.0 This message does not have authentication information or fails to pass 421-4.7.0 authentication checks. To best protect our users from spam, the 421-4.7.0 message has been blocked. 

Maybe I am not understanding your problem correctly, you need to describe exact use case with some good example.

sorry was busy couldn’t reply

Mx record at gmail?
i haven’t set up anything like that not yet because i am using webmail (rainloop)

the problem:
when i sent email from gmail to mail@mywebsite.com > (rainloop cyberpanel) <>i can’t receive email here (cant recieve on mail@mywebsite.com which is rainloop cyberpanel) .
but when i send from my website to (from mail@mywebsite.com) > gmail then i can receive on gmail.

maybe i should open a ticket?

When you send email from your server (in this case from Rainloop), your server just sends out your message by finding MX record of Gmail or any domain you are sending to. MX is a DNS record type that tells the world the location of the mail server for your domain.

You just need to set up MX record for your domain so that Gmail can find your mail server, for your reference https://support.cloudflare.com/hc/en-us/articles/218069617-How-do-I-add-or-edit-mail-or-MX-records-

ok now i have added mx record in my cloudflare but still i can’t seem to receive mail and i am getting this error in cloudflare “An MX record was not found for your root domain. An MX record is required for mail to reach @website.com addresses.”

FOR SOME REASON DELETING AND RE-ADDING MX RECORD seems to fix the receiving issue but some of the mails never arrived… i am still testing it. (on my web mail)

EDIT: if i reply back to my email from gmail to my website email then i can receive that msg but if i compose a new one then it never arrives … (from gmail to my web mail)

Still, your records are not correct, paste your MX records below, first, you need an MX record and then A record as well.

See MX section on this link.

Still, your records are not correct, paste your MX records below, first, you need an MX record and then A record as well.

See MX section on this link.

everything was fine! since i had migrated from godaddy it still had the old record which i forgot to delete and don’t know why it was way at the end of dns list in cloudflare so couldn’t spot it :disappointed:
now i can receive emails but some of them are delayed like 30mins-1 hour the rest is all good

Thanks a lot you mentioned the A record else i would never be able to solve it :smiley:

Still, your records are not correct, paste your MX records below, first, you need an MX record and then A record as well.

See MX section on this link.

everything was fine! since i had migrated from godaddy it still had the old record which i forgot to delete and don’t know why it was way at the end of dns list in cloudflare so couldn’t spot it :disappointed:
now i can receive emails but some of them are delayed like 30mins-1 hour the rest is all good

Thanks a lot you mentioned the A record else i would never be able to solve it :smiley:

Check and see if you don’t have multiple MX records if you have old MX record it might be trying to send an email there causing the delay on your actual mail server.

a

Still, your records are not correct, paste your MX records below, first, you need an MX record and then A record as well.

See MX section on this link.

everything was fine! since i had migrated from godaddy it still had the old record which i forgot to delete and don’t know why it was way at the end of dns list in cloudflare so couldn’t spot it :disappointed:
now i can receive emails but some of them are delayed like 30mins-1 hour the rest is all good

Thanks a lot you mentioned the A record else i would never be able to solve it :smiley:

Check and see if you don’t have multiple MX records if you have old MX record it might be trying to send an email there causing the delay on your actual mail server.

after everything is done now i have problem sending an email to yahoo.
my ip seems to be blacklisted in CBL abuseat

Your IP address (123.456.789) is sending email in such a way as to strongly indicate that the IP itself is operating somes sort of spam package.

This IP is impersonating (via SMTP HELO command) being a domain we know it cannot be. No properly configured mail server does this under any circumstances.

i think this is an configuration error as it says “sending email in such a way as to strongly indicate that the IP itself is operating somes sort of spam package”
i don’t know whats wrong i have checked and scanned both my website and Computer and couldn’t find a single trace of malware/virus

kindly help me once again :smiley:

Did you do 2 - SSL For PostFix/Dovecot - CyberPanel

If this doesn’t fix your issue then you need to get a clean IP or submit a ticket with more details.

Hello
I have a weird issue.
Yesterday i´ve installed the cyberpanel… and looks all ok and without errors.
I´ve already added a new domain, set nameservers, update its in the registrar, all looks ok. Yesterday, i was able to send emails using rainloop but i got some dns errors (not propagated properly)

Today : i send an email and i got it inmediatly.
But when i try to send an email from rainloop, simply i presss in the “send button” and appears a little message : “can´t send message” without any other error ;(

IN mail logs:

Sep 21 19:55:37 CentOS-75-64-minimal postfix/submission/smtpd[14673]: D00A81020B01: reject: DATA from localhost.localdomain[127.0.0.1]: 450 4.7.1 : Data command rejected: Service temporarily unavailable; from=hello@MYDOMAIN.com to=info@TARGETDOMAIN.com proto=ESMTP helo=<www.MYDOMAIN.com>

Any clue ?

I run intoDNS: MYDOMAIN.COM - check DNS server and mail server health and all looks perfect

Regards
Fabian

disable email policy server.

I just disabled it.

But now:

RainLoop Webmail cannot access to the data folder “/usr/local/lscp/cyberpanel/rainloop/data/”

Before to ask here… i do this:

;(

Thanks
Fabian