Websites appearing as offline on, but fixed temporarily after CSF reset

Hi all,

So I’ve just found out tools like and ConvertKit mark all the websites on my server as offline. The websites aren’t offline though, and when I stop and start the CSF firewall, they appear online for a few hours (haven’t been able to get an exact timespan yet).

This is an issue because customers connect their wordpress to external services, and some of these services mark the websites as unreachable.

Because the issue is resolved after a CSF restart, it seems that the issue must lay there. But I could really use some help in finding where to look and what to do. Any ideas are most welcome.

I tried the fetch the sites with using different methods (get, post, head, options) and all return a valid website. Uptimerobot also sees the websites as online. Just some services don’t and i’m afraid this affects the websites on more areas then just these two tools I tried (maybe even search enginges)

Sometimes this could be an ISP issue, try using VPN with the same network and the website will load.