Website cannot be accessed via domain, took too long to respond

I just installed cyberpanel on GCP using a public image. When I access it via Public IP, it is accessible. But when I connect the domain, name server, etc. It can’t be accessed, it’s marked “Took too long to respond” on chrome desktop (windows) and “ERR_CONNECTION_TIMED_OUT” on chrome android.

Here’s my website

If via IP it can be accessed and displayed, but if via this domain it cannot be accessed

Please help for the solution.

Make sure you have whitelisted/unblocked port 80 in your GCP firewall
Also try a server restart and see if it helps.

I have tried, but still “Took too long to respond” ERR_EMPTY_RESPONSE

Can only be accessed via IP only.

When I try to access the panel via url Hide It can be accessed, but for the main domain It can’t be accessed

This is because you haven’t configured DNS for your domain. I can see that your domain is pointing to server ip but your GCP server IP is different.

Also, please hide your server IP from here as this is public forum and anyone could see it.

You can send such sensitive details in private message.

Thanks for the help, my problem has been resolved, it turns out that the Server IP in the cyberpanel installation is not the same as my GCP IP, so I changed it manually via ssh, maybe because I had time to stop the machine, then turn it on so that it changed the initial IP.


thank you so much

1 Like

Glad that this is solved. Marking this thread as closed.