Web Terminal

CyberPanel v1.9.2 onwards have web terminal (to access your server SSH). However, in some browser, you might not be able to use Web Terminal with default self-signed SSL. In that case just setup CyberPanel on SSL. Now access CyberPanel using that domain.

Once you are done issuing SSL for CyberPanel make sure you also restart SSH server from here → https://:8090/Terminal/

Port 5678

SSH Server uses port 5678, this will be opened by default in new installations of CyberPanel. In case you choose to install CSF, make sure to open this port for Web Terminal to work.

Older installations can use normal procedure to add this port to either firewalld (normal firewall available with CyberPanel) or from CSF.


Authentication Failed

If you see this error, refresh the page and check if the problem is resolved. Otherwise, click Reboot SSH Server.

Error connecting to backend or connection closed.

Click Reboot SSH Server or go to the command line and run: ps aux | grep CPWeb, output will be like:

[root@server ~]# ps aux | grep CPWeb                                                                              
root     11093  0.5  1.3 546664 25460 ?        Sl   09:20   0:01 /usr/local/CyberPanel/p3/bin/python3 /usr/local/CyberCP

Here 11093 is the process ID of SSH server, you will have to manually kill this process using kill -9 PID and the refresh the terminal page.

1 Like

I have click on Reboot SSH Server but still same error.
OS: Ubuntu 20.04 on Proxmox CT (LXC).

my webssh not working too
with same result with @KotaKomputer

1 Like
  1. LXC is not tested by us.
  2. Your CyberPanel is on valid SSL?

You are on secure connection or on IP:8090?

Valid SSL

I Use default configuration after install. no other setting except aptget update upgrade
no firewall modified (actually i dont know firewall rule are on or not hahah) i never touch that configuration. not only at cyberpanel, cpanel plesk cwp. i always let everything on based installation configuration

$ kill -9 2813
-bash: kill: (2813) - Operation not permitted

i see this pleae help

No such process :hear_no_evil:

I tried this but did not work.

root@panel:~# ps aux | grep CPWeb
root      148385  0.0  0.0   6440   656 pts/1    S+   09:33   0:00 grep --color=auto CPWeb
root@panel:~# kill -9 148385
-bash: kill: (148385) - No such process

This feature was discontinued [BUG] Terminal Vanished from Latest version · Issue #1006 · usmannasir/cyberpanel · GitHub

Yes, same issue.

Ohhh, the feature is discontinued :smiling_face_with_tear:

Any updates? Or function is dead? Or devs are dead?)

is CyberPanel a good feature on proxmox or its exclusively designed for VPS?

really a very useful resource, it’s a shame it was discontinued =/