web not accessible after enabling firewall

hi
any one face such issue
firewall is blocking me to access website / control panel , even not able to add records , i Nees to stop with " systemctl stop firewalld" .

1 Like

I do update cyperpanel but sill same issue ! any idea

here are the commands, add port manually to solve this issue

firewall-cmd --add-service=ftp

firewall-cmd --add-service=http

firewall-cmd --add-service=https

firewall-cmd --zone=public --add-port=8090/tcp

1 Like

[09-04-40-Fri-May-2018] #########################################################################

[09-04-40-Fri-May-2018] FirewallD successfully enabled on system startup!

[09-04-40-Fri-May-2018] #########################################################################

FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running
FirewallD is not running

https://bugzilla.redhat.com/show_bug.cgi?id=1575845

what I guess is because of bug with ver 1.6.4 or need to run without yum update , the previous one was working fine

what I guess is because of bug with ver 1.6.4 or need to run without yum update , the previous one was working fine

There is something wrong with Centos 7.5, firewalld does not start. Or even in Centos 7.3 after yum update.

hi;

I am sure somehow it is cyberpanel bugs,

it is saving when adding a new rule , bt not updating old rules so you need add them manually.

you have two choice -

first stop firewall form ssh

systemctl stop firewalld

1- delete rules one by one and add them manually
[ OR ]
2- replace attached public.xml file located in >> /etc/firewalld/zones

reboot

hi;

I am sure somehow it is cyberpanel bugs,

it is saving when adding a new rule , bt not updating old rules so you need add them manually.

you have two choice -

first stop firewall form ssh

systemctl stop firewalld

1- delete rules one by one and add them manually
[ OR ]
2- replace attached public.xml file located in >> /etc/firewalld/zones

reboot

You are testing firewalld on plain or CyberPanel server?

on CyberPanel server

I am having this situation. However, it depends on the VPS installed. Some VPS has such a firewall error, others don’t

Just ran into this myself. FTP was the only thing enabled. Everything else had to be enabled. After the reboot, I got kicked out of everything, including SSH. Fortunately, I was able to use the console connection my host has to get around that and enable HTTP, HTTPS, and add the needed ports. Props to @khamiss for adding the commands to manually fix the problem.