Very Strange domain setup ERROR! It is deleting SUDO!

Hi All, I am having the strangest errors on my server.

It does not like challengersudoku .com or challengersudoku .co .uk and I don’t know why. It’s deleting characters (‘sudo’) out of my domain name!!!

I’m adding a new website to my server as I have done for years,

The domain is - ‘challengersudoku .com

it installs OK but as soon as I try and install WordPress, it fails. I then load the file manager and I see NO folders, I then try and create a file or folder and it fails without error every time! I then check ‘vHost Conf’ and I get this error …

‘cat: /usr/local/lsws/conf/vhosts/challengerku .com/vhost .conf: No such file or directory’

… and as you can see it has my domain name wrong, ‘sudo’ is gone. It’s showing it as challengerku .com and not challengersudoku .com. Why is it doing that?

The basic CyberPanel holding page shows under challengersudoku .com, but I can’t do anything.

The same happens with challengersudoku. co. uk, exactly the same.

I then try and install another domain name I have that I have not used yet, evforecourts .co .uk, and it installs and loads with no problems!

My friend also has Cyber Panel so I install it on his, the same problem!

Strange as it sounds, I then tried to install it as a child site under another of my domains and it worked! No problem (apart from I can’t run email off it. If I can pls let me know how).

Any help would be appreciated.

By the way, I had to put spaces between the dots in my domain names in this post or it would not allow me to post this message as I’m a new poster.

sudo is a linux operation command and maybe the recent security patches added by cyberpanel restricts the use of linux operations in it. I am just guessing this and it seems an issue/possible bug which needs to be fixed.

For now what you can do is, as you mentioned that you can create this under child domain, there is an option inside child domain to convert it to website. Click on it and see if it could convert it back to website properly.

Convert to a website does not work. That’s one of many things, over many hours I did try today. I does not work.

This is a bug, a big bug really. Right now, no domain name containing the word SUDO can be registered through this control panel.

I could register it many months ago, it was working, now it’s not working anymore. Which means an update has caused this issue.

Also stops me creating files and directories through the site file manager.

How long to get this fixed do you know? I need to setup a website, and I can’t.

Cyberpanel is been audited by Rack911labs and as per their recommendation many domain names are restricted to use in cyberpanel for rock solid security. sudo is a linux term and it refers to root user permission. I exactly don’t know if sudo is in blacklist domains list and the best person to answer this would be @usmannasir

This maybe an intentional change and not be a bug as far as I am aware. Bug is something which surfaces without intent for it.

It has to be a bug as there is no logical sense to create functionality of registering a domain name as long as the word SUDO is not in it. That’s crazy.

So words like Sudoku, which is a popular game and what my site is about can’t be used?

Also, if this was by design, a error message or an alert would appear stating that the registration of this domain is not possible and not allow me to register it. But instead it allows it to continue and creates incorrect configs all over the place making the domain impossible to use.

This is a bug.

As I said, I am not aware about sudo word blacklisting. I mentioned that there was recent security patches done as per recommendation from Rack911labs to blacklist certain domains. I am not very sure about the changes done as I havent checked the codes/changes done lately on github branch.

I believe this blacklisting of domains are intentional and done on purpose and not bug. But sudo in domain should have been included/whitelisted.

I will check the details in github soon and let you know.

Hi @die2mrw007

Appreciate the help on this. Currently running the site as a child domain from another site but this is not good as the domain can’t be setup with email.