Use PHP 8.3 width CyberPanel

I have updated CyberPanel to the latest version, specifically as follows: version 2.3, build 5, latest commit: 121e848a3d3d0d2dd69fd9bffdcb45d4affbf2e9
But currently in the list I only see php 8.2 and not php 8.3. So, I want to use php 8.3, what should I do?

Thank you!

Install php through system package manager and CyberPanel will detect it.

I do not understand. Can you give more detailed step-by-step instructions? Thank you!

your operating system?

I am using Ubuntu 22.04 64bit operating system.


apt-get purge lsphp83
apt-get install lsphp83*

After I ran the above 2 commands one after another, the problem was resolved. Thanks you very much.

I ran the command below but the php 8.3 extension in CyberPanel does not have memcache causing my website to error.

sudo apt install php8.3-memcached

Help me. Thanks you!

Is Redis and Memcache missing from lsphp83?

let me check

In the repository jammy here, php 8.3 has some extensions like memcached,… but in the list of php 8.3 in my CyberPanel there are no these extensions. Please ask how to update. Thank you!

@usmannasir hello sir!

Some PHP extensions are missing on ARM64.

I installed cyberpanel on an x86 and ARM64.
Since PHP 8.3 wasn’t installed with cyberpanel by default I followed the instructions:

apt-get purge lsphp83
apt-get install lsphp83*

This installed PHP 8.3 on both servers except that some PHP extensions are missing on ARM64.

On x86 all the PHP-Extensions are installed - a total of 25 extensions.
On ARM64 only 20 PHP-Extensions are installed.

These are the missing extensions on ARM64:

Usually for x86 the “Description” would read:
Eg., lsphp83-redis on AMD x86
lsphp83-redis/jammy,now 6.0.2-1+jammy amd64 [installed]

For ARM64:
On Ampere Altra
lsphp82-redis/jammy,now 5.3.7-1+jammy arm64 [installed]

Please look into it.
Thanks a lot.

God bless.