Update issue


Installation is Vultr one click Install.
Version was V2.3.?? Sorry I didn’t take note of build before I updated.
New version installed to via GUI install button v2.3.5

I had an issue with letsencrypt issuing SSL Certs they wouldn’t auto renew and when I renewed manually the would say the updated but they never did, I got an email from the instance saying it didn’t work. Checked certs and they still had the old install dates.
I was previous version of cyberpanel v2.3 and I did the update from the GUI to v2.3.5 and I got this error


Error: Reverse for ‘ResetDNSConfigurations’ not found. ‘ResetDNSConfigurations’ is not a valid view function or pattern name.

When I restarted the above error is gone and I get his error now


Error: (1146, “Table ‘cyberpanel.IncBackups_oneclickbackups’ doesn’t exist”)

I checked the logs and they are empty.
I cleared the logs before updating as to just keep the upgrade info and nothing was saved to them.

Websites are working and so is email. Just the web interface is in error.

Any ideas.

for this can you please run update once again and let me know if fixed or not?

Hi Mate

I can’t run the update through the GUI as it just gives this error on every page i select. what’s the ssh command

please update your server from the terminal using the guide 02 - Upgrading CyberPanel

Sorted thank you.

Does the error persist? Or were you able to come up with a solution?

Hi @Nimlot

the issue is somewhat sorted, i reinstalled from the SSH terminal and it started working, and for some reason ubuntu was picking up the port 80 HTTP request and it was failing at letsEncrypt. i am trying to sort now and get back to you.

Hello @DanielCollins

My problem was not solved with the update. I had to install ubuntu 20.04. I recommend you to switch to Ubuntu 20.04. If you do not have the old version of PHP you are using, it would be better to switch.

Hi I think I worked it out, it is working at the moment and only time will tell if it fixes it permanently.

I am running Ubuntu V20 LTS.

I ran command

systemctl stop apache2

This stopped Apache 2 on Ubuntu and it doesn’t pick up the http requests any more and they work as expected.