Unknown mail transport error / queue active

Hello,
incoming mails are in queue.
mail log:
postfix/qmgr[5435]: 3B16946AE69: from=xxxxxx@xxxxxxxx.com, size=4146, nrcpt=1 (queue active)

mailq
AEC2A46AE6E 12186 Tue Oct 1 00:36:54 ssssssss@ssssssssss.com
(unknown mail transport error)
zzzz@zzzzz.com

postfix flush

postfix: Postfix is running with backwards-compatible default settings
postfix: See Postfix Backwards-Compatibility Safety Net for details
postfix: To disable backwards compatibility use “postconf compatibility_level=2” and “postfix reload”
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_sender_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_client_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_helo_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_sender_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_client_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_helo_restrictions
/usr/sbin/postconf: warning: /etc/postfix/main.cf: undefined parameter: virtual_mailbox_limit_maps
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_extended=yes

Please help

I just happened this, I still haven’t found the real cause (100% effective, but I’ve managed to make it work) @franko

1º remove spamassing

  • ssh: yum remove spamassing

2º remove residuals
rm -Rf /etc/mail/spamassassin
(i use nano, you cand use vi or vim) nano /etc/postfix/master.cf

remplace
smtp inet n - n - - smtpd -o content_filter=spamassassin

to
smtp inet n - n - - smtpd

and remove last line
spamassassin unix - n n - - pipe flags=R user=spamd argv=/usr/bin/spamc -e /usr/sbin/sendmail -oi -f ${sender} ${recipient}

3º add permissions dovecot
nano /etc/dovecot/dovecot.conf and and this lines at the end of the document

service stats {
unix_listener stats-reader {
user = vmail
group = vmail
mode = 0660
}

unix_listener stats-writer {
    user = vmail
    group = vmail
    mode = 0660
}

}

4º restart services
systemctl restart dovecot
systemctl restart postfix

5º remove queue (The queue was not sent, I had to eliminate it)
postsuper -d ALL

we are Using cyberpanel 2.1.1 on centos 7.9 server.
and we are tempting to install spamassassin from cyberpanel menu.
result was not really good.

  1. spam service unable to start. try to open spamd port, restart dovecot / postfix was not working. error msg spamd: could not create IO::Socket::IP socket on. didnt find any clue on it.
  2. try to remove spamassassin and using @thisjrodriguez recommendation, email are working again. thanks mate!

should be something wrong with spamassassin.