Unable to totally remove SpamAssassin

I installed SpamAssassin through Mail Settings > SpamAssassin

However it was blocking all email, so I used this command to uninstall it.
apt-get remove spamassassin && apt-get purge --auto-remove spamassassin

But I am still not getting emails.

My email logs also show:
Dec 8 21:08:46 frontandback postfix/smtpd[395535]: 7417584688: client=mail-lf1-f54.google.com[209.85.167.54]
Dec 8 21:08:46 frontandback postfix/cleanup[395605]: 7417584688: message-id=CAHX2OPzbmhe=N3fyoYzu2L5_=QNH5GWfU+-hhKf7ZALvut0+rg@mail.gmail.com
Dec 8 21:08:46 frontandback postfix/qmgr[395451]: 7417584688: from=sleggat@gmail.com, size=16710, nrcpt=1 (queue active)
Dec 8 21:08:46 frontandback postfix/pipe[395606]: 7417584688: to=me@steveleggat.com, relay=spamassassin, delay=0.18, delays=0.16/0.01/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: pipe: fatal: pipe_command: execvp /usr/bin/spamc: No such file or directory )

Looking in my master.cf file I still have these entries (I have done ‘postfix reload’ and still the same).

smtp inet n - n - - smtpd -o content_filter=spamassassin
dovecot unix - n n - - pipe
flags=DRhu user=vmail:vmail argv=/usr/libexec/dovecot/deliver -f ${sender} -d ${recipient}
spamassassin unix - n n - - pipe flags=R user=spamd argv=/usr/bin/spamc -e /usr/sbin/sendmail -oi -f ${sender} ${recipient}

How would I completely remove spammassassin/spamd/spamc?

Okay, I may have it working;

I removed ’ -o content_filter=spamassassin’ from the smtp line and removed this line;
spamassassin unix - n n - - pipe flags=R user=spamd argv=/usr/bin/spamc -e /usr/sbin/sendmail -oi -f ${sender} ${recipient}

No errors on the log and mail is flowing again. Scary when that happens!

https://installlion.com/ubuntu/vivid/main/s/spamassassin/uninstall/index.html
check this guide