Unable to open sites with http

I recently rebooted my VDS (Ubuntu 20.04) and after that, sites are unable to open via http.

http://domain.com loads index of/

But the sites work fine via https protocol: https://domain.com

I’ve restarted the server several times via command line: systemctl restart lscpd but the problem is still there.

My Cyberpanel installation is up to date by the way. Is someone else facing the sort of problem?

Hello @JosephChuksT Happy you are here

Remove Apache completely. You server is running cyberpanel alongside apache.

sudo apt remove apache2.*

Hi @josephgodwinke, thank you for the response. I ran the command as you advised but the problem is still there. Here’s a screenshot of the result:



which apache2
# if something is returned continue
sudo service apache2 stop
sudo apt-get purge apache2 apache2-utils apache2.2-bin apache2-common
sudo rm -rf /etc/apache2
sudo apt autoremove
1 Like

I ran the commands you listed. see the result:

And after getting 503 error for a while, I did a restart:
systemctl restart lscpd

And the sites are now working via http.

Thank you very much @josephgodwinke

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.