Unable to establish connection for SMTP

Hello guys. The connection could not be established even though the ports are open.
But I can send and receive in e-mail programs. DNS records are fine. Only my server is not connecting to remote smtp server. Could Postfix be the cause?

Terminal command;

telnet smtp.yandex.com 587

I can’t connect to smtp servers through my server. Anyone know the reason for this?

I get this issue every 3 month, even SSL is valid ports open etc… Can send and receive normal from snappy mail but SMTP get error “tls_process_server_certificate:certificate verify failed”
Easiest fix I found I have to buy email debugger every 3month and run it to fix issue…

This should not be the solution. There is a blocking and you say it’s because of the certificate. If the problem is the certificate, this should be resolved. I’ve been searching for two days. I tried many things. Telnet still not responding. Therefore, mail cannot be sent because the smtp server does not respond.

Try run test //email/testTo: for your email and see what result is.

1 Like

I looked. The problem is just not being able to connect to smtp from our server. We have to find its source.