Unable to access phpmyadmin in AlmaLinux 8

I’m getting “Composer detected issues in your platform: Your Composer dependencies require the following PHP extensions to be installed: json” error while accessing phpmyadmin.

I think there is some issue with php 8.1 in latest update. I’m unable to edit php 8.1, getting this error “Cannot fetch details. Error message: PHP matching query does not exist.”.

I tried the latest version in CentOS 7 and didn’t face such issue. Is there anything wrong with latest AlmaLinux? or Cyberpanel 2.3?

Already tried existing solution available on this forum, none of them is working for me

Can you please run update and try again?

I tried to update everything/reinstall alma linux/Manually checked and install missing php modules, but none of them worked. I think php was not installed properly in alma, even “php -m” was not executing. I had to reinstall php through yum, to run “php -m” command

My sites was down, so I reinstall CentOS

In CentOS, I can access phpmyadmin but that php 8.1 error is still there. But I can run php commands in terminal

Can you change the server php version and try?

I have experienced the same issue.

Try installing Cyberpanel on Ubuntu and you should not experience those issues.

Hi! Same problem here.


Hi again!

I fixed reinstall one by one php extensions (php 7.3)