Ubuntu 22.04 using Python 3.10.6 - Problem with new installation

I’m installing CyberPanel on Hetzner using Ubuntu 22.04.

Collecting decorator==3.4.0
  Downloading decorator-3.4.0.tar.gz (30 kB)
  Preparing metadata (setup.py) ... error
  error: subprocess-exited-with-error

  × python setup.py egg_info did not run successfully.
  │ exit code: 1
  ╰─> [1 lines of output]
      error in decorator setup command: use_2to3 is invalid.
      [end of output]

  note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

pip install --default-timeout=3600 -r /usr/local/requirments.txt has failed for 1 times
Wait for 3 seconds and try again...

Python version = Python 3.10.6

Happy New Year @sidneyandrewss

Are you installing the stable version or a specific version ?

Can you get a clean install of Ubuntu 22 and install Python 3.8.10

Try install with that because cyberpanel is only specific that you use version 3 the semantic minor and patch versioning is not really checked.

I’ve done several clean installs, including removing python3.10 and installing version 3.8.
On installation he unzips the python3.10 package and the problems continue.
Thank you for your help.

Are you installing the stable version ?

That’s right!
I gave up, I believe that to automate more than 50 installations I would have many problems, who knows in the future. Thanks.

Ubuntu 22 - stable version works perfectly. There has not been any change on stable version since January 23, 2023. You have to use the stable version and nothing else with Ubuntu 22

That’s exactly where the problem is, the version I use is Ubuntu 22.04 LTS and nothing else.
I tried using CentOS 8, AlmaLinux and the problems are the same.
Only by installing the server and running the package update and then installing CyberPanel do errors appear during the installer.

1 Like

@josephgodwinke Thanks for the help, at the moment I won’t waste any more time, maybe in the next few weeks I’ll try again, thanks.


Ok hopefully will se you back here again. If you need any help just reach us here.

I have the same problem.
Tried alma, then rocky. it is just plain OS install, run the command and got this error.
It is not good to welcome with these errors right from the first step!
Is there a way to fix this issue?