Ubuntu 22.04 Unable to Install CyberPanel

I am following the steps given in Documentation for Installation of CyberPanel and getting the following error

chmod: cannot access ‘cyberpanel.sh’: No such file or directory
/dev/fd/63: 49: ./cyberpanel.sh: not found

I am running Ubuntu 22.04 and have gone through the command to update and upgrade already.

Pls help and advise.


I am also getting this - on investigation it appears that cyberpanel.sh is blocking certain IP ranges. In my case they are both in South Africa but on different hosts. If I run the VPS through a VPN and change the IP address to one elsewhere (like Germany) then the installation continues.
However on restart of services the IP address goes back to a South African one and it cannot continue. So am also stuck with this.

One VPS is Alma8 and the other is Ubuntu 20.04, both completely new with updates done.

I can connect fine with wget and curl to https://cyberpanel.net so it appears it is just on the https://cyberpanel.sh domain that I cannot wget or curl from.

Testing on identical VPS hosted in Germany and the UK everything works fine, so pretty sure this is a Geoblock of some kind to the repo

I am having this issue as well and have tried from two different service providers in the Caribbean. I haven’t tried this from a Cloud VPS yet. Thank you for posting as I did not know what to make of this when I tried to test the panel for the first time. Edit: This is on Ubuntu 22.04, same as OP.

A quick test to demonstrate

from server in GB

lynx https://cyberpanel.sh/?country

response: GB

From 2 servers in ZA
Looking up cyberpanel.sh
Making HTTPS connection to cyberpanel.sh
Retrying connection without TLS.
Looking up cyberpanel.sh
Making HTTPS connection to cyberpanel.sh
Alert!: Unable to make secure connection to remote host.

lynx: Can’t access startfile https://cyberpanel.sh/?country

for me it does not seems to be a connection issue … pls see the ping. I am also able to open the site on browser but file is still not on the server

working on something… will update if it works

Its working for me now … on its own.

pls try at your end

awesome, working now thanks! :nerd_face: