Too many failed login attempts on SSH port 22

Hi Everyone,

Hope you are having a great day.

Recently I have been facing too many failed login attempts on SSH port 22 from Chinese & Korean IP’s. I have not yet implemented SSH login using only SSH keys added in cyberpanel.

I guess that may help in resolving this issue but sometimes I use login using password on my another system that is why I have not disabled the login with password.

Kindly suggest me any best practices to keep the CyberPanel based server secure & keeping the password based login enabled also if possible. @usmannasir @die2mrw007


change ssh port
and change your public ip

i never use that

easier to change ssh port

To make secure do these things.

  1. Block the ips from provider.
  2. disable the ssh password auth
  3. change ssh access port

The best practice is always to use SSH key login and disable password based login. Password based logins are not at all safe and can be cracked in many cases. This is the reason why big providers like AWS, Google cloud, and others have SSH key login only as the option to access the server. They do not provide an option for password logins in any of their platforms.


This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.