Suddenly storage almost full

Hi to all, 2 days ago the storage of my vps from 40% went almost full.
I have hosted my website on contabo, using Ubuntu 20.04.
In the server i have 2 sites in total almost 3gb: Upload and share screenshots and images - print screen online |
i tried to identify the problem, it seems the storage problem is in the usr folder: Upload and share screenshots and images - print screen online |
What should i do to find what causing this problem?
Thanks in advance

Which folder inside /usr is taking space? could be lscache data.

you are correct !
i found that the /usr/local/lsws/cachedata is the majority of the used space.
I am deleting the files, but due to the big amount of the folders the server kicked me out. I beleive that
have to wait until tomorrow to access again the server and delete the rest.

Is there a way to auto delete the cachedata files or i have to manual do it ?sa

you have set long TTL for your cache?

I don’t remember if i have set something different from the default, where can i check it please ?


Have a look at this specially to the bottom of the article, LiteSpeed have provided some utilities regarding this, maybe you can run them via cron.

Hi again almost a week after, the same storage problem appeared, so i had to delete again the cachedata folder.

Also i am experiencing 100% cpu usage that slows down the entire eshop.

The 100% cpu usage appeared almost 2 weeks ago, the top processes are:

The 1st time this happened i changed server, but the problem is still here.

i noticed that there is a new openlitespeed version: v1.7.19.1 that mentions:
[Bug Fix] Fix a HTTP/3 integration issue that causes high CPU usage.

the current version i have is 1.7.18, can i safely upgrade? If yes is there any guide ?

depending upon the OS, just do openlitespeed upgrade and you will get new ols version and its safe.

1 Like

Hi again, i made the update today

i still get 100% cpu usage. the only difference is that the storage increasing seems to be fixed, until now only 1% increased.
I am really desperate

On your above screen shot looks like lots of lsphp processes, best place to discuss that would be:

Hopeful update:
I changed the php version from 8.1 to 8.2 and it seems that the cpu usage is back to normal and not 100%
I will monitoring the behavior for a couple of days and i will inform if the problem solved.
Thanks for the support