Suddenly Power DNS and PureFTPD Stopped

Hi, Suddenly my clients server’s Suddenly Power DNS and PureFTPD Stopped working. After clicking on restart and start button it does nothing.
I was running cyberpanel v1.8.0. And then an update might solve the problem. So i upgraded and its still not working. What should i do ?

Same here!

CentOS 7, Cyberpanel 1.9

I updated CentOS and Cyberpanel, but it’s still not working.
Server status > Services status page indicates: OpenLiteSpeed - Running, MariaDB - Running, PowerDNS - Stopped (with green Play icon) and PureFTPd - Stopped (with orange Pause icon).

https://prnt.sc/p91jl6
Same here on my Production Server :neutral:

@CyberPanel

https://prnt.sc/p91tha
Unable to open /etc/pdns/pdns.conf

I’m using this code as the solution to the same problem I have;

pdns_server --config-dir=/etc/pdns/

but after a while the power dns shuts down again.

how do i do that ? can you elaborate. Actually I am very new to all this vps server management.

I'm using this code as the solution to the same problem I have;

pdns_server --config-dir=/etc/pdns/

but after a while the power dns shuts down again.

I run this command in my ssh command line interface and power dns and pure ftp started .
Dont know how much time this will remain solved.
Thanks for the help.

I'm using this code as the solution to the same problem I have;

pdns_server --config-dir=/etc/pdns/

but after a while the power dns shuts down again.

Thanks Man
https://prnt.sc/p963x6

Confirm costlasweb! Same problem here! Command “chown pdns:pdns /etc/pdns/pdns.conf” doesn’t work anymore.

I think i should move to another panel like centos web panel. these problems are irritating and also we loose our reputation in front of clients.

It should be like

[root@ok7jva7ctt pdns]# ls -la
total 44
drwxr-xr-x.  2 root root  4096 Oct  4 02:00 .
drwxr-xr-x. 89 root root  4096 Sep 18 12:50 ..
-rw-r--r--.  1 root root 15714 Aug  8 15:06 pdns.conf

Working now! I have changed pdns.conf permissions:
chmod 666 /etc/pdns/pdns.conf

Yeah for anyone else if you “stat” the file it should show the exact number like the example with 644 provided by cyberpanel above. Mine was actually set to 600 and was working and tested with 666 to like above and it also works. So 600,644,666 should work.

CentOS
chown root:root /etc/pdns/pdns.conf
chmod 644 /etc/pdns/pdns.conf

Ubuntu path is slightly different.
chown root:root /etc/powerdns/pdns.conf
chmod 644 /etc/powerdns/pdns.conf

Then use systemctl to start/stop/restart

systemctl start pdns
systemctl restart pdns
systemctl status pdns

Example:
Centos
[root@wcloud:~]# stat /etc/pdns/pdns.conf
File: ‘/etc/pdns/pdns.conf’
Size: 15680 Blocks: 32 IO Block: 4096 regular file
Device: fd01h/64769d Inode: 386219 Links: 1
Access: (0644/-rw-r–r–) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2019-09-07 10:32:58.445839561 -0400
Modify: 2019-08-20 23:25:08.501273032 -0400
Change: 2019-10-04 09:11:49.169724817 -0400
Birth: -
[root@wcloud:~]#

Ubuntu
root@rst:/etc/powerdns# stat /etc/powerdns/pdns.conf
File: /etc/powerdns/pdns.conf
Size: 15714 Blocks: 32 IO Block: 4096 regular file
Device: 801h/2049d Inode: 517909 Links: 1
Access: (0644/-rw-r–r–) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2019-05-11 07:08:37.954140041 -0400
Modify: 2019-05-11 07:08:37.958140041 -0400
Change: 2019-10-04 09:14:21.034326231 -0400
Birth: -
root@rst:/etc/powerdns#

yeah, this was most likely due to running it manually as a command “pdns_server --config-dir=/etc/pdns/” which got killed vs in daemon mode via systemctl like “systemctl restart pdns” how it’s normally managed.

thanks everyone, I have solved it. I did it like this …

[root@vmi241085 ~]# cd /etc/pdns
[root@vmi241085 pdns]# ls -la
total 44
drwxr-xr-x 2 root root 4096 Oct 4 02:00 .
drwxr-xr-x. 83 root root 4096 Oct 4 11:38 …
-rw------- 1 pdns pdns 15680 Jun 9 20:00 pdns.conf
-rw------- 1 root root 17069 Aug 28 19:31 pdns.conf.rpmnew
[root@vmi241085 pdns]# chmod 666 /etc/pdns/pdns.conf
[root@vmi241085 pdns]# ls -la
total 44
drwxr-xr-x 2 root root 4096 Oct 4 02:00 .
drwxr-xr-x. 83 root root 4096 Oct 4 11:38 …
-rw-rw-rw- 1 pdns pdns 15680 Jun 9 20:00 pdns.conf
-rw------- 1 root root 17069 Aug 28 19:31 pdns.conf.rpmnew
[root@vmi241085 pdns]# chown root:root /etc/pdns/pdns.conf
[root@vmi241085 pdns]# ls -la
total 44
drwxr-xr-x 2 root root 4096 Oct 4 02:00 .
drwxr-xr-x. 83 root root 4096 Oct 4 11:38 …
-rw-rw-rw- 1 root root 15680 Jun 9 20:00 pdns.conf
-rw------- 1 root root 17069 Aug 28 19:31 pdns.conf.rpmnew
[root@vmi241085 pdns]# systemctl start pdns
[root@vmi241085 pdns]# systemctl restart pdns
[root@vmi241085 pdns]# systemctl status pdns
● pdns.service - PowerDNS Authoritative Server
Loaded: loaded (/usr/lib/systemd/system/pdns.service; enabled; vendor preset: disabled)
Active: active (running) since Sun 2019-10-06 10:24:14 CEST; 13s ago
Docs: man:pdns_server(1)
man:pdns_control(1)
https://doc.powerdns.com
Main PID: 18687 (pdns_server)
CGroup: /system.slice/pdns.service
└─18687 /usr/sbin/pdns_server --guardian=no --daemon=no --disable-…

Oct 06 10:24:13 vmi241085.contaboserver.net pdns_server[18687]: TCP server bo…
Oct 06 10:24:13 vmi241085.contaboserver.net pdns_server[18687]: TCPv6 server …
Oct 06 10:24:13 vmi241085.contaboserver.net pdns_server[18687]: PowerDNS Auth…
Oct 06 10:24:13 vmi241085.contaboserver.net pdns_server[18687]: Using 64-bits…
Oct 06 10:24:13 vmi241085.contaboserver.net pdns_server[18687]: PowerDNS come…
Oct 06 10:24:14 vmi241085.contaboserver.net pdns_server[18687]: Polled securi…
Oct 06 10:24:14 vmi241085.contaboserver.net pdns_server[18687]: Creating back…
Oct 06 10:24:14 vmi241085.contaboserver.net pdns_server[18687]: About to crea…
Oct 06 10:24:14 vmi241085.contaboserver.net systemd[1]: Started PowerDNS Auth…
Oct 06 10:24:14 vmi241085.contaboserver.net pdns_server[18687]: Done launchin…
Hint: Some lines were ellipsized, use -l to show in full.
[root@vmi241085 pdns]#