I have a domain, which is currently running on a server. Let’s call it Server A. And I have installed cyberpanel on another server (Server B), and added a subdomain of the one on Server A this another server.

DNS record should be correct. I have tried pinging this new subdomain and it correctly points to Server B. The main domain is kept with Server A as Server B is only for testing purpose.

However, when I tried to access this subdomain through web browser, it returned ERR_TOO_MANY_REDIRECTS.

I followed 3 - Creating and Managing Child Domains to create the subdomain after I created a dummy site for the main domain on the Server B. So I am not sure what the problem is.


Check → Making sub domain gives wrong permission

can you give here your domain name ?
there is many reason we cannot open the website with ERR_TOO_MANY_REDIRECT
htacces/ssl - DNS Problem - application - etc.

I have same issue. Please I need HELP.
the subdomain in questions is
PLEASE HELP, I am totally new to this. I inspected the browser and saw error 302

i need screenshoot your ns zone …
if your domain use IN NS
then i need screenshoot the ns zone inside cyberpanel

this is not 100% can solve because webscript,ssl,ns record, can be the problem
so i will TRY help you solving this 1 by 1

what is content in htaccess?

1 Like

Thank you for your support. Find attached, This is for the mother domain -

I hope this is what you want me to share though ?

Thank you for your interest in supporting me to fix this issue;
Here’s the .htaccess :slight_smile:

RewriteEngine On
Options +FollowSymLinks
Options -Indexes
RewriteCond %{SCRIPT_FILENAME} !-d
RewriteCond %{SCRIPT_FILENAME} !-f
RewriteRule . index.php [L,QSA]

Performace optimization

BEGIN Compress text files

AddOutputFilterByType DEFLATE text/html text/xml text/css text/plain AddOutputFilterByType DEFLATE image/svg+xml application/xhtml+xml application/xml AddOutputFilterByType DEFLATE application/rdf+xml application/rss+xml application/atom+xml AddOutputFilterByType DEFLATE text/javascript application/javascript application/x-javascript application/json AddOutputFilterByType DEFLATE application/x-font-ttf application/x-font-otf AddOutputFilterByType DEFLATE font/truetype font/opentype # END Compress text files

BEGIN Expire headers

ExpiresActive On ExpiresDefault "access plus 5 seconds" ExpiresByType image/x-icon "access plus 31536000 seconds" ExpiresByType image/jpeg "access plus 31536000 seconds" ExpiresByType image/png "access plus 31536000 seconds" ExpiresByType image/gif "access plus 31536000 seconds" ExpiresByType application/x-shockwave-flash "access plus 31536000 seconds" ExpiresByType text/css "access plus 31536000 seconds" ExpiresByType text/javascript "access plus 31536000 seconds" ExpiresByType application/javascript "access plus 31536000 seconds" ExpiresByType application/x-javascript "access plus 31536000 seconds" # END Expire headers

BEGIN Cache-Control Headers

Header set Cache-Control "public" Header set Cache-Control "public" Header set Cache-Control "private" Header set Cache-Control "private, must-revalidate"

<filesMatch “.(woff|woff2|ttf|otf|eot)$”>
Header set Cache-Control “max-age=31536000 private, must-revalidate”

END Cache-Control Headers

how if you put news file at public_html
and insert any text inside it ?
then try open sub.domain.tld/test.html

and you should test @shoaibkk solution later, that can be from htaccess too

Thank you for your support, I did as you suggested about creating a dummy test.html in the root folder (public_html) and then call the subdomain( but it still came back with the error as shown in the screenshot.

Waiting for what I can do again, thanks

Yes I have sent to @shoaibkk the content of my .htaccess file, waiting for his reply.
Thanks all for this support

did u use home.html/html
index.htm html
for the test file ?

because i try = result 404

close all browser
change your DNS to other ip
or else
then ipconfig /flushdns
then try use private browser/ igconigto mode

1 Like

Thank you so much @MyIDKaTePe . I don’t know how but somehow the subdomain in now working. But I observed that there’s now a index.html file inside the subdomain directory itself now. Previously, it wasn’t there but now it show.
Being a part of this community is awesome, I am grateful.

1 Like

solved ?
im verry happy your problem can be solved

Thank you so much. You are very helpful.
Now I have another request, I am trying to install NodeJs in this sub-directory, via the terminal, I don’t know how to pull this through. Can u help

New thread please :smiley:

mark this thread with “solution” solved
then create new thread with new problem.

1 Like