SSL Mail Madness

I had this issue some time ago and though that issuing a Mail SSL fixed it, though it didn’t and it’s weird.

I tried to see with checktls about a domain of mine But the reply I have comes from another domain (which is the last domain I manually issued the Mail SSL!!!)

Old thread: PHP Mailer - Wrong domain - #2 by shoaibkk

One thing I saw, is that the websites had an directory, I deleted it. Nothing changed, it still continues to not work like this.

Why is it so hard to just press the renew ssl and play nice, as every hosting platform. DNS and everything is configured. A and MX records exists.

Seems that running the following solves the issue:

postmap -F hash:/etc/postfix/
systemctl restart postfix

But now from a contact form, if I use domain ( is not working. I have to use the Cyberpanel’s DNS name to work.

Also sending an email with these settings I get an issue with this:

The IP address sending this message does not 550-5.7.25 have a PTR record setup, or the corresponding forward DNS entry does 550-5.7.25 not point to the sending IP. As a policy, Gmail does not accept 550-5.7.25 messages from IPs with missing PTR records.

Hello @apo208

You are missing a rDNS PTR record. Did you add the mail subdomain as PTR record for your server ?


Yes it is right now the right one. The mail server is CyberPanel’s domain now and the PTR record too.

Running this

postmap -F hash:/etc/postfix/

fixed the issue with the Cert FAIL in checktls. But now if I want any service (Wordpress contact form for example) to use the email, I have to use the as SMTP server and I cannot use the

What error are you getting on wordpress ?

Well I have again this issue. I really gonna change to CWP.

My rDNS is set to my server domain. I want to send an email from another domain whish is hosted on the server and I get this issue from the gmail.

How can I fix this s**t? Last time it worked when I issued an SSL for the mail server and now it stopped working as expected.