SSL issued to "example.com"

Hey guys,

I tried to google it, I found some result, but I didnt solve it.

I made many website, never issue. after some time I made new website, issued SSL, but I am getting error because my SSL was issued NOT to my domain, but www.example.com.

I tested it on 3 different not used domains I have bought while ago. All same issue.

Thanks!
I am sorry if that was solved already, no solutions I found didnt help me.

Its a well-known problem atm, please follow this guide: https://pcx3.com/cyberpanel/cyberpanel-self-signed-certificate-issue/

Hey,

thanks for this article!
I followed it step by step and I got generated files.
but I only got fullchain.pem and privkey.pem
cert.pem is missing in the folder for some reason.
Can I use fullchain.pem instead of cert.pem?

thank you

Hi OndrejP,

The 2 files should be printed out to the terminal after running step4. so you should be able to copy them from the terminal directly…

anyway, yes you can, fullchain.pem consists of both cert + priv.key so just edit the file and copy the part starting from -----BEGIN CERTIFICATE----- all the way to the -----END CERTIFICATE----- line.

Hope that resolves the issue. Cheers!

Yes, second try worked! thanks!

how can I apply this also for subdomain please

Hello,

My server has the same issue, then I tried to follow the guide, then got an error message in step 4 during generating new cert:
“Please specify at least one validation method: ‘–webroot’, ‘–standalone’, ‘–apache’, ‘–nginx’ or ‘–dns’ etc”

How can I fix this problem? Thanks.

Hi there,

If adding --standalone to command line arguments did nothing, then change Le_Webroot=’’ to Le_Webroot=‘no’ inside the /<domain-name.conf> file.

As stated here: error "Please specify at least one validation method" (2nd posting) · Issue #1172 · acmesh-official/acme.sh · GitHub

Cheers!

how I can apply this guide for subdomain please

Hi there, sorry for a late response.

Just add the subdomain to the command in step 4. for example: -d

Make sure the subdomain is created and pointing to the server first.