Ssh + added public kay but need password

i add public key and when i use
ssh some@some.com

still ask for password.

You need to disable password authentication from sshd_config file

Maybe this can help you How to Disable SSH Password Authentication on Linux VPS