[SOLVED] Trying to import a database via phpmyadmin fails

Hello again :wink:

I’m having great difficulty trying to import databases. I have several sites I am trying to clone to the new CyberPanel installation and the smallest db file I have is 5mb with the largest at 35mb they all fail with the “connection_reset” error

I have adjusted all the memory limits I can find, I have done so via the php config editor with in CyberPanel. When at the import screen of phpmyadmin I show the max file size at 100MiB, this should be sufficient right?

Is there a limit I should be checking elsewhere? When I run an import from a 50K sql file, it works fine.

Also, why don’t I see changes to the max limit on the upload when making changes via the php config editor? I have made edits on all the php 7 (7.0, 7.1, 7.2)

I know Chrome can be notorious for chaching issues, so I have also tried this via an incognito window.

Thanks … Scott

So I made another attempt to edit the php configs by following this …

I was doing this the same way before, with the exception of the server restart. I couldn’t remember the command so I went in via the server status link in CyberPanel. There are four services listed as running - OLS, MariaDB, PowerDNS, and PureFTPd - I was restarting OLS via this panel but nothing would update for the memory allocation.

I changed all the memory limits to 200mb, did a restart via command line of lscpd and presto, the memory limit showed 200MiB and the sql import went through just fine.

I’m still confused as to why the limit of 100MiB was not sufficient when I couldn’t even get a 5mb file to import.

Normally the actual allowed import limit is displayed itself in PHPMYAdmin, and I think you were only missing ‘systemctl restart lscpd’ ?

I have a similar situation. Download database to import to another host normally. But with Cyberpanel VPS, import error not connect, ssl error …

Normally the actual allowed import limit is displayed itself in PHPMYAdmin, and I think you were only missing 'systemctl restart lscpd' ?

I have similar problem too. allowed import limit 2gb but when importing .sql gives an error: connection reset. so i can’t import db file.

searched a lot but didn’t find any solution.

need a help asap


Use command line.

anyone solved this please? I changed the limits but phpmyadmin is still showing maximium 2Mb

The solution is simple and I tested twice just to be sure :grinning::+1:

The problem is because phpMyAdmin uses php version 7.3 (at this moment)

So you need to update upload_max_filesize on the correct version of php (doesn´t matter whats your site is using it)

1 Like

On my PHP version it is set max upload size to 1024M but still when I hit GO in import it gives 500 error


Maybe I have found a solution. I was getting the same error, but then I uploaded my DB after compressing it in a zip file.

example.sql >> example.sql.zip

500 error on sql import - no solution so far - php import limited are more than enough

someone solved ?

Hi Guys,

Check cyberpanel version, if it is not up to date, update it and try importing db.