Snappymail admin panel - not able to log in

I have been able to log in to the admin panel some time ago, but when I try now, I am not able to log in.

Also, I have searched the forum and have tried some of the suggestions, but so far, no luck.

Any ideas?

Hello @Oceanwatcher

Using ssh terminal log into your server and run the command

nano /usr/local/lscp/cyberpanel/rainloop/data/_data_/_default_/admin_password.txt || vi /usr/local/lscp/cyberpanel/rainloop/data/_data_/_default_/admin_password.txt

Thats where you admin password is. Use it to log in to snappymail admin panel

Thank you for responding. Would be nice if it worked. I assume the text in that file is the password, as there is nothing else that a short text.

I am on Ubuntu if it makes any difference.

A few months ago, I logged in to the admin panel and I changed the login. I do have that login as it is stored in


But that one is not working either.

Have you tried to reset the password SnappyMail admin password reset - #2 by seanfitz09

Yes. Tried it and nothing happened. I commented out the old user and password. Rebooted the whole server. But nothing new. The user and pass is still commented out.

This should remain as is. For some reason you have to try everal times until it goes through

What do you mean I should try several times? Obviously there is a bug here somewhere…

Is snappymail a service that can be retarted, or just a php (or similar) script?

Stop interfering with the application.ini. SnappyMail creates a new admin password for you when application.ini has empty admin_password entry.

Also your issue has nothing to do with cyberpanel so if you still cannot get this working I would recommend you open an issue here Issues · the-djmaze/snappymail · GitHub

Snappymail does NOT generate a new admin password when the old is commented out. I am not sure what you mean by stop interfering. I am following the instructions about this as well as I can.

You are now saying that admin_password should be empty. That is not what the instructions say. There, it says it should be commented out. Which one is correct?

Which instructions are you following ?