SMTP Server SSL Issues When Connecting To Gmail

Hi. I set up the emails and installed the SSL. When connecting it to Gmail, the pop server is connecting without issues. But when connecting SMTP it is giving mi SSL error.
Error: TLS Negotiation failed, the certificate doesn’t match the host., code: 550

Welcome @abdosarmini Happy you are here

You need to verify you mailserver domain ssl here SSL Checker type in (change to the actual mailserver domain name) post results here


You have SMTP delivery issues. Check if you have unblocked all smtp ports in your firewalls? If this is digital ocean or linode contact your service provider to help you

I am using Hostinger VPS hosting. There is firewall section in the cyberpanel. Is it something there or in the Hostinger settings?

Also I checked from this site //email/testTo: and there is a warning in yellow

You have a Self signed certificate issue try these steps Self Signed SSL Issue · josephgodwinkimani/cyberpanel Wiki · GitHub

This is what it shows in the cyberpanel emails page

Did you try port 25 ?

Port 25 worked only with the not secure connection

Good that means your SMTP configurations are ok you just need to fix the ssl issues with link shared

I enabled the firewall by a mistake from cyberpanel and now I can’t access it. How can I turn it off using ssh?

After enabling it I can’t access the panel

firewall-cmd --permanent --zone=public --add-port=25/tcp
firewall-cmd --permanent --zone=public --add-port=587/tcp
firewall-cmd --permanent --zone=public --add-port=465/tcp

Still I can’t access the panel at all

systemctl stop firewalld.service

What did you do for this to happen ?

It is working now. I just hit the green start button in the firewall page and then I couldn’t access the panel anymore.

Stop firewalld from sshd and try fix your issue SMTP Server SSL Issues When Connecting To Gmail - #18 by josephgodwinke