SLOW - LiteSpeed Cache

Website is super super super slow… (+1 min to load page >>> inspect >> network) but disable Litespeed plugin the website work normal speed…

Please help

Hello @lmilani Happy you are here

You need to tweak the plugin settings to fine tune your caching. If it ia big site I recommend a proper CDN some CDNs break caching functionalities of wp plugins like quic-cloud queue issues and use edge side includes (this requires LiteSpeed Web ADC - Load Balancer - LiteSpeed Technologies )

You also need to check plugin conflicts especially langauge switchers, other caching plugins.

As a start go to LiteSpeed Cache → Toolbox → Debug Settings and set Disable All Features to ON

1 Like

Good afternoon, it is strange because I have 4 vps in Contabo that use CyberPanel and only in 1 of them do I have this generalized problem of Litespeed leaving all the sites where it is installed super slow. the problem is only overcome when I disable the wordpress plugin (litespeed).
Any more suggestions?

Have you checked this tutorial to see if you configured it correctly https://www.cyberhosting.org/how-to-optimize-wordpress-site-using-lscache-plugin/

If all servers are setup the same and have same resources then it seems you have an issue with a problematic JS or CSS file. Try the by excluding these js/css files for homepage and test page speed before and after


I see all servers and think alls configs is the same =

LITESPEED STATUS:

On this page you can get information regarding your LiteSpeed processes.

VERSION: LITESPEED/1.7.16 OPEN (BUILD BUILT: THU NOV 17 16:18:46 UTC 2022)

module versions:
lsquic 3.1.1
modgzip 1.1
cache 1.64
mod_security 1.4

Have you tried the following

  1. Adjust LiteSpeed Cache > Settings > Tuning
  2. Exclude JS/CSS Files for a single page
  3. Install htop and monitor server load when you visit any page on the website. If you have post a screenshot so that we can see server load.