S3 Backup Stopped Working

S3 backup stopped working after upgrading to version 1.8.2. It was working fine in 1.8.1. I didn’t change any setting in the server after upgrading to 1.8.2. I even tried opening the port 5003 after seeing the backup log but that too doesn’t help.

Backup Log :

HTTPConnectionPool(host=‘localhost’, port=5003): Max retries exceeded with url: /backup/submitBackupCreation (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object at 0x7f670a52f990>: Failed to establish a new connection: [Errno 111] Connection refused’,))

Great pick, we will fix it.

Found another bug. Can’t add new server to the platform. It says API access disabled.
Imgur

You need to enable API Access from under User menu.

@Luke007

For your S3 issue upgrade and try again. Upgrading CyberPanel - CyberPanel

Let me know if your issue is still not resolved.

@CyberPanel The issue is resolved. But the backup process seems to have become more CPU intensive than before. Too many tasks run under the user “cyberpanel” and chokes up the CPU. Is this normal during remote backup?

Just so you know the backup process used is same as old.

@CyberPanel Well, there is still some bug in S3 backup. Automatic scheduled backup doesn’t work. Only forced backup works

Do you have anything in error logs?

Nothing in the error logs.

I fixed this bug, upgrade.

You will also have to reconnect your AWS Account and then add the backup plan.