Problem with the certificate of the mail subdomain

Hello, my thunderbird was working correctly for several months and since few days it just stopped pulling messages from the server and I also can’t send messages. This is the message Thunderbird gives me when trying to send an email.

Sending of the message failed.
The certificate is not trusted because it is self-signed.
The configuration related to must be corrected.

These are my DNS records:

I have tried to manually issue certificates and it works. But when thunderbird check or it can’t find certificate. However, when it checks for, without the ports, it finds the certificate.

My Cyberpanel version is 2.1.2 and I haven’t updated anything in the server for few months. The Thunderbird was working correctly until few days ago.

EDIT: Forgot to mention that sending and receiving in rainloop (webmail) works. I have also disabled the antivirus and double checked if the ports has been blocked.

Try upgrading your cyberpanel setup using this

sh <(curl || wget -O -

Although your version number is latest, still run the above upgrade command.

Check if upgrading solves the issue. If not, try connecting your cyberpanel to and use the Email debugger there. If you are unable to access email debugger, then raise a support ticket there requesting access to email debugger and it will be granted.

Hello, thank you for your help!

I receive the following fail when trying the command:

Run this command first

sudo su -

then run this command:

sh <(curl || wget -O -

Upgraded and the Thunderbird works now. Thank you!