Problem with nvidia

Dear All,

now after fresh install of alma9.3, I had problem with nvidia:
I was keep receiving:
info: task gnome-shell:1946 blocked for more than 122 seconds

I tried to solve it by adding following to linux line in grub *at the start of boot:

it solved but now I have the rough resolution and nvidia is not detected:
I tried to install nvidia using following (can search it by install nvidia alma linux):
mokutil --sb-state
sudo dnf config-manager --set-enabled crb
sudo dnf install
epel-release-latest-9.noarch.rpm (link)

sudo dnf config-manager --add-repo rhel9/$(uname -i)/cuda-rhel9.repo (link)

sudo dnf install kernel-headers-$(uname -r) kernel-devel-$(uname -r) tar bzip2 make automake gcc gcc-c++ pciutils elfutils-libelf-devel libglvnd-opengl libglvnd-glx libglvnd-devel acpid pkgconfig dkms

sudo dnf module install nvidia-driver:latest-dkms

All was successfull, but after reboot and
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

(PS: I think the problem started when I try to run this to solve gtk issue:
yum update --nogpgcheck)

shows nothing.

All The Best