Problem install CyberPanel

Using cached decorator-3.4.0.tar.gz (30 kB)
Preparing metadata (setup.py) … error
ERROR: Command errored out with exit status 1:
command: /usr/local/CyberPanel/bin/python3 -c ‘import io, os, sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/tmp/pip-install-lz0jfzca/decorator_67bbc185e31d481ba01dfe1d4570c8af/setup.py’"’"’; file=’"’"’/tmp/pip-install-lz0jfzca/decorator_67bbc185e31d481ba01dfe1d4570c8af/setup.py’"’"’;f = getattr(tokenize, ‘"’"‘open’"’"’, open)(file) if os.path.exists(file) else io.StringIO(’"’"‘from setuptools import setup; setup()’"’"’);code = f.read().replace(’"’"’\r
‘"’"’, ‘"’"’
‘"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ egg_info --egg-base /tmp/pip-pip-egg-info-rzuiu96f
cwd: /tmp/pip-install-lz0jfzca/decorator_67bbc185e31d481ba01dfe1d4570c8af/
Complete output (1 lines):
error in decorator setup command: use_2to3 is invalid.

WARNING: Discarding https://files.pythonhosted.org/packages/f3/26/876d492f2394f29401eb652ddfa53dec2bc8721861c7fe0dce1b5d0d2b6a/decorator-3.4.0.tar.gz#sha256=c20b404cbb7ee5cebd506688e0114e3cd76f5ce233805a51f36e1a7988d9d783 (from Links for decorator). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
ERROR: Could not find a version that satisfies the requirement decorator==3.4.0 (from versions: 3.3.1, 3.3.2, 3.3.3, 3.4.0, 3.4.2, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.6, 4.0.8, 4.0.9, 4.0.10, 4.0.11, 4.1.0, 4.1.1, 4.1.2, 4.2.1, 4.3.0, 4.3.1, 4.3.2, 4.4.0, 4.4.1, 4.4.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 5.0.8, 5.0.9, 5.1.0)
ERROR: No matching distribution found for decorator==3.4.0

pip install --default-timeout=3600 -r /usr/local/requirments.txt has failed for 23 times
Wait for 3 seconds and try again…

i have the same problem when i try to install it on centos 8

Please provide more details like which hosting, server specs and error logs

Have you tried reinstalling cyberpanel?

this is the error that generates when I try to install cyberpanel

ERROR: Command errored out with exit status 1:
command: /usr/local/CyberPanel/bin/python3 -c ‘import io, os, sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/tmp/pip-install-v0kpqi57/decorator_333b750ad5bd4ce39dcaa2cba2ca3663/setup.py’"’"’; file=’"’"’/tmp/pip-install-v0kpqi57/decorator_333b750ad5bd4ce39dcaa2cba2ca3663/setup.py’"’"’;f = getattr(tokenize, ‘"’"‘open’"’"’, open)(file) if os.path.exists(file) else io.StringIO(’"’"‘from setuptools import setup; setup()’"’"’);code = f.read().replace(’"’"’\r\n’"’"’, ‘"’"’\n’"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ egg_info --egg-base /tmp/pip-pip-egg-info-pupbrkh9
cwd: /tmp/pip-install-v0kpqi57/decorator_333b750ad5bd4ce39dcaa2cba2ca3663/
Complete output (2 lines):
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
error in decorator setup command: use_2to3 is invalid.

WARNING: Discarding https://files.pythonhosted.org/packages/f3/26/876d492f2394f29401eb652ddfa53dec2bc8721861c7fe0dce1b5d0d2b6a/decorator-3.4.0.tar.gz#sha256=c20b404cbb7ee5cebd506688e0114e3cd76f5ce233805a51f36e1a7988d9d783 (from Links for decorator). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
ERROR: Could not find a version that satisfies the requirement decorator==3.4.0 (from versions: 3.3.1, 3.3.2, 3.3.3, 3.4.0, 3.4.2, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.6, 4.0.8, 4.0.9, 4.0.10, 4.0.11, 4.1.0, 4.1.1, 4.1.2, 4.2.1, 4.3.0, 4.3.1, 4.3.2, 4.4.0, 4.4.1, 4.4.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 5.0.8, 5.0.9, 5.1.0)
ERROR: No matching distribution found for decorator==3.4.0

How you installed Centos8? Is it by the hosting provided image? Which hosting?
If possible, do provide a temporary login access to your server SSH and I will try to install this and see how it goes and find a possible solution if I get this same error while installation.

I see that it is already something from the software, I tried it from centos 7 with an iso downloaded from the provider but the failure is the same with the decorator.

ERROR: Command errored out with exit status 1:
command: /usr/local/CyberPanel/bin/python3 -c ‘import io, os, sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/tmp/pip-install-v__pdvip/decorator_ff76246ceeb54b548bc9dacb03f2cde6/setup.py’"’"’; file=’"’"’/tmp/pip-install-v__pdvip/decorator_ff76246ceeb54b548bc9dacb03f2cde6/setup.py’"’"’;f = getattr(tokenize, ‘"’"‘open’"’"’, open)(file) if os.path.exists(file) else io.StringIO(’"’"‘from setuptools import setup; setup()’"’"’);code = f.read().replace(’"’"’\r\n’"’"’, ‘"’"’\n’"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ egg_info --egg-base /tmp/pip-pip-egg-info-s334j_ro
cwd: /tmp/pip-install-v__pdvip/decorator_ff76246ceeb54b548bc9dacb03f2cde6/
Complete output (1 lines):
error in decorator setup command: use_2to3 is invalid.

WARNING: Discarding https://files.pythonhosted.org/packages/f3/26/876d492f2394f29401eb652ddfa53dec2bc8721861c7fe0dce1b5d0d2b6a/decorator-3.4.0.tar.gz#sha256=c20b404cbb7ee5cebd506688e0114e3cd76f5ce233805a51f36e1a7988d9d783 (from Links for decorator). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
ERROR: Could not find a version that satisfies the requirement decorator==3.4.0 (from versions: 3.3.1, 3.3.2, 3.3.3, 3.4.0, 3.4.2, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.6, 4.0.8, 4.0.9, 4.0.10, 4.0.11, 4.1.0, 4.1.1, 4.1.2, 4.2.1, 4.3.0, 4.3.1, 4.3.2, 4.4.0, 4.4.1, 4.4.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 5.0.8, 5.0.9, 5.1.0)

ERROR: No matching distribution found for decorator==3.4.0

I tried other versions that module but nothing, I have no problem giving you access, you can tell me where I can send you the information

Please private message me here and I will take a look.

Hello, I can solve the problem because of the cyberpanel script install decorator 5.1.0, I had to install it through the pip install decorator and look for the version that the software actually needs

1 Like