Problem connecting to mail server from Thunderbird

I am trying to connect Thunderbird to the email I set up. The email address is 100% working. I even got it set up and working with Thunderbird on one computer. However, from that computer, I can receive but not send emails.

Now, I have tried to set it up on another computer with Thunderbird and through an Android app client (Boxer) and neither of them can connect. Thunderbird give me the error: “Thunderbird failed to find the settings for your email account”.

I have set up TLS with Let’s Encrypt already. Anybody have any idea what I can do to troubleshoot this? I am at a loss.

Turns out that it is working on Thunderbird, but it seems that SMTP is not working correctly. Thunderbird wouldn’t let me set up SMTP at first. So, I was able to add the email, but I cannot send any emails. Receiving emails works just fine.

The android app won’t let me connect at all because it is unable to connect to SMTP. Thanks for any help.

Please read this guide → 6 - Self-signed SSL error on Outlook/Thunderbird - CyberPanel

Thanks. I tried that in the past but it didn’t work. I went over it again and it worked. I must have made a typo or two.

FYI, there is a type in the first code block. “it has” instead of “live/”.

Also the first part of this is rather vaguely worded and confusing, it left me unsure if I was supposed to do certain things.

Thanks a lot for your help!