Prestashop SSL Invalid token

After installing prestashop at I navigate to Shop Parameters, General and click check for SSL support. This gives me this error:

Invalid token: direct access to this link may lead to a potential security breach.
Do you want to display this page?

If I except the risk and go on the site drops into https, but hangs.

On refresh SSL is still off.

I know this is more a prestashop issue, but I was wondering if anyone else has seen this problem and any suggestions.

On a side not is markup available for this forum, I tried, but didn’t seem to work?


So before enabling SSL from PrestaShop, did you have valid SSL for your site?

Yes I did. I had WordPress running there with SSL. I removed and installed Prestashop.
I have tried regenerating the SSL. “Enable SSL on all pages” is always greyed out.

I also get 404 Page not found if I enable Friendly URL’s ?

I’ve just noticed what seems to be a related problem. 2 other websites on Cyberpanel ( these are WordPress) using SSL are unable to login. I try and login and it just waits with the status bar saying “Sending request to

EDIT: Had a eureka moment. I’d enabled modsec a couple of days ago. I disabled this and the problems mostly vanished.

I still get the Invalid token error, but I’m able to click on accept and continue to setup Prestashop and use SSL

Friendly URL’s 404’s problems - needed to clear cache and it also seems to work

Can you submit ticket and mention steps to reproduce the problem? Also, mention your OpenLiteSpeed version.