PowerDNS running successfully, but DNS not working. How to identify problem from terminal?

I want to change the NS zone so that DNS records can be managed from the cyberpanel, but PowerDNS does not work correctly, because nslookup utility reports server not found domain by ip and list zone = 0.
root@cp ~ # pdns_control list-zones
All zonecount:0

Now all DNS records are in Hetzner.

How to identify problem from terminal?

Also I see that the domain is duplicated in the address. Yesterday I ran the upgrade script for cyberpanel

@usmannasir @tmoore

All working)) I`m delete CNAME

MariaDB [cyberpanel]> delete from records where domain_id=1 and type=“CNAME”;

And everything worked, all domains open. BUT! When I returned all CNAMEs back, everything also continues to work. I never understood what it was

#bug BUG in Cyberpanel: Serial number DNS in SOA not update automatically after editing DNS

I’m not a cyberpanel dev.

Regarding your issue, I Will see tomorrow if i can figure out whats the issue, not at pc today.

Edit: nvm I saw you fixed your issue

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.