postfix problem

hey all
it is a bit to long to explain so here is the log that says it all

or in short, a basic non edited install of cyberpanel is trowing this error
a reinstall of postfix dit not fix it eather

12/20/2019 12:32:56 - [IsMyEmailWorking.com email test started]
12/20/2019 12:32:58 - [Querying DNS for responsible mail servers for ‘serverhosting.tech’]
12/20/2019 12:32:58 - [Starting DNS Session]
12/20/2019 12:32:58 - [RFC 5321 5. The lookup first attempts to locate an MX record associated with the name. If a CNAME record is found, the resulting name is processed as if it were the initial name. If no MX records are found, but an A RR is found, the A RR is treated as if it was associated with an implicit MX RR, with a preference of 0, pointing to that host.]
12/20/2019 12:32:58 - [Trying to get MX Records for ‘serverhosting.tech’]
12/20/2019 12:32:59 - [Found MX Record ‘mail.serverhosting.tech’ Preference ‘10’]
12/20/2019 12:32:59 - [Found 1 MX Records]
12/20/2019 12:32:59 - [Searching Found MX Records for Host Records]
12/20/2019 12:32:59 - [MX Record ‘mail.serverhosting.tech’ Did not include any Host records. Queueing ‘mail.serverhosting.tech’ for further resolution.]
12/20/2019 12:32:59 - [Performing Additional Queries for Host records for MX Records that are queued for further resolution]
12/20/2019 12:32:59 - [Found an A Host Record for ‘mail.serverhosting.tech’ of ‘185.55.95.91’]
12/20/2019 12:32:59 - [Completed Additional Queries for Host records]
12/20/2019 12:32:59 - [DNS Session completed]
12/20/2019 12:32:59 - [Found 1 responsible mail servers for ‘serverhosting.tech’]
12/20/2019 12:33:02 - [Selected target email server to test ‘First Available’]
12/20/2019 12:33:04 - [Starting SMTP Session]
12/20/2019 12:33:04 - [Attempting to connect to ‘mail.serverhosting.tech/185.55.95.91’]
12/20/2019 12:33:04 - [Connecting to 185.55.95.91:25.]
12/20/2019 12:33:04 - [Connected, localEP=‘108.60.212.145:55983’; remoteEP=‘185.55.95.91:25’.]
12/20/2019 12:33:04 - 220 panel.serverhosting.tech ESMTP Postfix
12/20/2019 12:33:04 - [Successfully connected to ‘mail.serverhosting.tech/185.55.95.91’]
12/20/2019 12:33:05 - [Attempting to transmit ‘helo/ehlo’]
12/20/2019 12:33:05 - EHLO IsMyEmailWorking.com
12/20/2019 12:33:05 - 250-panel.serverhosting.tech
12/20/2019 12:33:05 - 250-PIPELINING
12/20/2019 12:33:05 - 250-SIZE 30720000
12/20/2019 12:33:05 - 250-VRFY
12/20/2019 12:33:05 - 250-ETRN
12/20/2019 12:33:05 - 250-STARTTLS
12/20/2019 12:33:05 - 250-AUTH PLAIN
12/20/2019 12:33:05 - 250-AUTH=PLAIN
12/20/2019 12:33:05 - 250-ENHANCEDSTATUSCODES
12/20/2019 12:33:05 - 250-8BITMIME
12/20/2019 12:33:05 - 250 DSN
12/20/2019 12:33:05 - [‘helo/ehlo’ transmitted Successfully]
12/20/2019 12:33:07 - [Attempting to transmit ‘mail from’]
12/20/2019 12:33:07 - MAIL FROM:test@ismyemailworking.com
12/20/2019 12:33:07 - 250 2.1.0 Ok
12/20/2019 12:33:07 - [‘mail from’ transmitted Successfully]
12/20/2019 12:33:08 - [Attempting to transmit ‘rcpt to’]
12/20/2019 12:33:08 - RCPT TO:support@serverhosting.tech
12/20/2019 12:33:08 - 451 4.3.5 support@serverhosting.tech: Recipient address rejected: Server configuration error
12/20/2019 12:33:08 - [Exception: 451 4.3.5 support@serverhosting.tech: Recipient address rejected: Server configuration error]
12/20/2019 12:33:08 - [‘rcpt to’ transmission failed]
12/20/2019 12:33:08 - [Attempting to disconnect]
12/20/2019 12:33:08 - QUIT
12/20/2019 12:33:08 - 221 2.0.0 Bye
12/20/2019 12:33:08 - [Disconnected.]
12/20/2019 12:33:08 - [Disconnect success, SMTP Session terminated]

a bit more information
[root@web ~]# postfix reload
postfix: Postfix is running with backwards-compatible default settings
postfix: See Postfix Backwards-Compatibility Safety Net for details
postfix: To disable backwards compatibility use “postconf compatibility_level=2” and “postfix reload”
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_se nder_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_cl ient_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_he lo_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_se nder_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_cl ient_restrictions
/usr/sbin/postconf: warning: /etc/postfix/master.cf: undefined parameter: mua_he lo_restrictions
/usr/sbin/postconf: warning: /etc/postfix/main.cf: undefined parameter: virtual_ mailbox_limit_maps
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_cre ate_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mai ldir_extended=yes
postfix/postfix-script: refreshing the Postfix mail system

same problem here

i got a hotfix for this
this happends if you use the following piping command
php -q /home
email piping do not work if you use “-q”’ in the field, as the “-” breaks the full script

and if you do not use it , then it does not work ( php /home does NOT work )

only way to fix it is by replacing the main.cfg and master.cfg back to the original before you added email piping

for me it just seems email piping is broken … probably because whmcs use dovecot instead postfix

Greets from PowerChaos