Postfix can't route email because Dovecot misses directory

Hello all,

I’m just linked an SMTP server because of routing issues though the state of the mailserver doesn’t seem to improve.

In both cases (default and SMTP setting) it complains about a missing folder from Dovecot.

When the ‘default’ setting is enabled (:8090 > Logs > Servermail) it is able to send but not receive and with SMTP enabled (also located in :8090 > Logs > Servermail) it gives an authentication error when trying to send an email.

The SMTP server is linked to my DNS correctly though I can’t verify if it handles the emails rights since dovecot seems to be missing a crucial folder. Should I maybe try to run the upgrade script? (I’m already on the latest cyberpanel version though maybe it installs some missing files?)

Missing folder error:
myemail@hotmail.com>, size=10640, nrcpt=1 (queue active) Mar 05 20:02:05 37-187-197-249 postfix/smtpd[10184]: disconnect from mail-am6eur 05olkn2087.outbound.protection.outlook.com[40.92.91.87] ehlo=1 starttls=0/1 mail =1 rcpt=1 bdat=1 quit=1 commands=5/6 Mar 05 20:02:05 37-187-197-249 postfix/pipe[10189]: 258E72330D: to=<ruben@projec tsincluded.com>, relay=dovecot, delay=0.41, delays=0.38/0/0/0.02, dsn=4.3.0, sta tus=deferred (temporary failure. Command output: pipe: fatal: pipe_command: exec vp /usr/libexec/dovecot/deliver: No such file or directory )

Which is weird since everything passes on the Network Tools: DNS,IP,Email

I also did the test on //email/testTo:

Checking projectsincluded.com from www11-do.CheckTLS.com:

seconds		lookup	result
[000.000]	    	DNS LOOKUPS
[000.022]	    	SEARCHLIST	104.131.108.216,134.209.169.224,1.1.1.1,8.8.8.8,67.207.67.3
[000.024]	    	MX	(0) mail.projectsincluded.com
[000.024]	    	MX	(10) mail.projectsincluded.com
[000.026]	    	MX:A-->mail.projectsincluded.com	37.187.xxx.xxx
[000.028]	    	MX:A-->mail.projectsincluded.com	37.187.xxx.xxx
seconds		test stage and result
[000.000]		Trying TLS on mail.projectsincluded.com[37.187.xxx.xxx:25] (0)
[000.077]		Server answered
[000.169]	<‑‑	220 mail.projectsincluded.com ESMTP Postfix
[000.169]		We are allowed to connect
[000.170]	‑‑>	EHLO www11-do.CheckTLS.com
[000.246]	<‑‑	250-mail.projectsincluded.com
250-PIPELINING
250-SIZE 30720000
250-ETRN
250-STARTTLS
250-AUTH PLAIN
250-AUTH=PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250 CHUNKING
[000.246]		We can use this server
[000.246]		TLS is an option on this server
[000.247]	‑‑>	STARTTLS
[000.323]	<‑‑	454 4.7.0 TLS not available due to local problem
[000.323]		STARTTLS command rejected
[000.324]	‑‑>	MAIL FROM:<test@checktls.com>
[000.400]	<‑‑	250 2.1.0 Ok
[000.401]		Sender is OK
[000.401]	‑‑>	QUIT
[000.503]	<‑‑	221 2.0.0 Bye 
seconds		test stage and result
[000.000]		Trying TLS on mail.projectsincluded.com[37.187.xxx.xxx:25] (10)
[000.076]		Server answered
[000.247]	<‑‑	220 mail.projectsincluded.com ESMTP Postfix
[000.248]		We are allowed to connect
[000.248]	‑‑>	EHLO www11-do.CheckTLS.com
[000.323]	<‑‑	250-mail.projectsincluded.com
250-PIPELINING
250-SIZE 30720000
250-ETRN
250-STARTTLS
250-AUTH PLAIN
250-AUTH=PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250 CHUNKING
[000.323]		We can use this server
[000.323]		TLS is an option on this server
[000.324]	‑‑>	STARTTLS
[000.405]	<‑‑	454 4.7.0 TLS not available due to local problem
[000.405]		STARTTLS command rejected
[000.405]	‑‑>	MAIL FROM:<test@checktls.com>
[000.481]	<‑‑	250 2.1.0 Ok
[000.481]		Sender is OK
[000.482]	‑‑>	QUIT
[000.574]	<‑‑	221 2.0.0 Bye

I’m not sure what is happening here nor how to fix it. Does anyone has any idea on how to fix it? It would be really appreciated!

Can you reset your email settings from CyberPanel cloud?

1 Like

Thank you, that did the trick @usmannasir!

I’m however stuck on another problem and that’s on how I make panel.projectsincluded.com and mail.projectsincluded.com work with Cloudflare so I don’t have to expose my IP (so instead of using 37.187.x.x:8090 I want to use both domains i.e. panel.projectsincluded.com with an SSL certificate). I’ve already found some posts about this topic on this forum but none of the solutions seem to work for me. (I’m using the latest version of Cyberpanel - v2.1, Build 2)

Within Cloudflare websockets are enabled and I already have a subdomain called panel.
According to Cyberpanel panel.projectsincluded.com also has a valid SSL certificate from Let's Encrypt.

Do you have any suggestions on how to solve this issue?

Cloudflare does not allow access to port 8090, you can change your CyberPanel port to 2083 and put it behind Cloudflare

it now partially works under my domain. I still need to add the port number after the URL like so:

panel.projectsincluded.com:2083

How can I remove this?

Removing port not recommended.